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Copyright Baldor  2000. All rights reserved.
This manual is copyrighted and all rights are reserved. This document may not, in
whole or in part, be copied or reproduced in any form without the prior written
consent of Baldor.
Baldor makes no representations or warranties with respect to the contents hereof
and specifically disclaims any implied warranties of fitness for any particular
purpose. The information in this document is subject to change without notice.
Baldor assumes no responsibility for any errors that may appear in this document.
Microsoft and MS–DOS are registered trademarks, and Windows is a trademark of
Microsoft Corporation.
UL and cUL are registered trademarks of Underwriters Laboratories.
This manual contains information pertaining to the Designer version 5.08 or later.

Introduction This manual is intended to provide a complete overview of the software and
project development.  For information regarding hardware operation, please see
MN1272 HMI Operator Panel Installation and Operating manual.  MN1272 also
provides the installation procedure for the software.

Editor Menus When Designer is started, the main menu appears.  The following pages describe
each of the main menu selections available on the pull down menus.

File Menu

Start a new project page.  (More than one project  can be open at one time.

Open an existing (previously saved) project page.

Save the active project page to a file.

Save the active project page to a different file than the current filename.

Print your entire project, a summary, pages, alarms, or variables.

Preview report.

Exit and close the Designer Software.

Specify printer and settings.
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Edit Menu 

Delete a data field or to move it to another position.

Copy a data field.

Used with Cut and Copy to place data in a new field.

In this mode, Cut/Copy/Paste commands work with all languages. Normally, the 
Cut/Copy/Paste commands work only with the active language (Section 12).
Selects the entire contents of the current page.

Adds a time data field to the current page.

Adds a date data field to the current page.
Configure panel data retentive memory to store controller data (recipes).

Allows reference of many controller memory locations from a single numeric field.

Assign the data field type (numeric/ASCII, bargraph, message, attribute).

Place special characters and symbols in the filed.

Assign the data field source (controller data, recipe data, panel control variable).

Draw rectangles and other symbols on your project page.

View Menu

Zoom In – makes image larger on screen.

Zoom Out – makes image smaller on screen.

Display/Hide the Toolbelt menu.

Display/Hide the Extra Toolbelt menu.

Display/Hide the Status Bar.

Toolbelt menu

Extra Toolbelt menu

Status Bar
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Page Menu

Insert a new blank page before the current page.

Add a new blank page at the end of the project file.

Selects which page of the project file will be the current page.

Displays the previous page of the file.

Displays the next page of the file.

Rename or link a page or set the page scrolling parameters.

Selects the desired page mode.

Allows Recipe configuration.

Page Options
� Rename the current page.
� Link the current page to the previous page or to the next page.
� Enable a page scroll frequency and the number of lines to scroll.  This allows

you to see lines that may be off the screen without having to use the arrow keys
to scroll through the information.

� Change the language used by the project file.
When pages are linked, the left and right arrow keys on the display panel may be
used to scroll between pages. The current page is linked to both the previous
page and the next page.
Note: If you are having problems using this feature, check the Project→RDA

Setup. Be sure the PR (page request) box in the PLC section is not
checked.

Special Pages and Page Modes

This screen will appear whenever you begin Data Entry Mode.

This menu appears when you press the ENTER key and holds it for a period of three
to four seconds.
Allows you to adjust the contrast or brightness and check communication.

This screen will appear when passwords from the Panel Command Menu is selected.

A snapshot of the controller’s memory (active only with 16 or 25 line display).

Scroll through the list of page names and select the page to be  displayed.
Allows you to set the time and date on the panel.

Appears whenever there is an active alarm, if C2 bit in the RDA is not set.

Displays the previous 256 events in sequential order.

Displays the current page of the project file.
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Page Menu Continued
Recipe Configure
A Recipe is a collection of data items on a particular page.  There can be up to
1024 data items of a single recipe, depending on the panel model.  A  data item is
a specific block of data within a recipe. All recipes contain data items but the
values of the data items vary. 

The Recipe Configure dialog allows you to:
– Specify the number of data items for the recipe on the current page.
– Specify initial values for all recipe data items on the current page.

Touchscreen Menu

Turns On/Off the grid in which touchcells can be created.

Show/hides the touchcells in a project file.

Display/Hide the Toolbox menu (creating touchcells, pushbuttons, indicator lamps, etc.).

Delete all touchcells and associated text or graphics, on the current page.

Select a font to be used for a touchcell.  NOT a global font and may be changed at
any time without affecting any of the previously created touchcells.

Touchscreen toolbox

Create a panel key touchcell.

Create a pushbutton touchcell.

Create a selector switch touchcell.

Create a touchcell and configure it as a panel
key, an ASCII character or as a macro command.

Select, move and resize objects.

Create an ASCII character touchcell.

Create an illuminated pushbutton touchcell.

Create an indicator lamp.

Note:  Place an LED indicator on the face of the
touchcell by clicking the Reference tab and mark-
ing the box Attach to controller reference.  The
LED will reflect the state of the address entered
in the Button reference box.

Gauge

Time/Date Box

Trend Viewer

Text Box
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Graphics Menu

Enhanced graphics, allows you to import bitmap graphics (also cut/paste).

Allows display of a graphic based upon a numeric value in the controller.

Display graphics as Transparent/Solid objects.

Allows you to place a bitmap graphic from the library into the project file.

ISA (Instrument Society of America) symbols can be placed into the project file.

Dynamic Graphics
Displays a graphic image based on a value from the controller.  Select
Graphics→Dynamic Graphics or the proper icon from the Extra ToolBelt.  For
example, you may want to display two graphics – one when a blower is on, and
one when a pump is on.

Project Menu

Select the controller being used.

Selects the panel type and specify memory and other items.

Select the font  to be used for the project.

Specify the model type and key parameters of the controller.

Specify the PLC address for the RDA (reserved data area).

Specify the controller address for the Interlock Mailbox.

A report is a collection of project file pages (or parts of project file pages).
(Printer setup, report format, triggers).
Allows the panel keys to perform application specific functions.

Define up to eight passwords with varying degrees of access rights.

Define up to 256 alarms.

Exchange data between two controllers or registers of a single  controller.

Create a single project with multiple languages (select at run time).

Displays panel memory and recipe memory used by project file.

Define your target system application name (stored in the program).
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Transfers Menu

Transfer the project file from the computer to the panel.

Transfer an existing application from target memory to PC memory.

Retrieve the configuration of the panel.

Run the application in target memory.  Communication is interrupted until target returns
to Configuration Mode.

Select the panel memory location, create a ROM file, etc.

Enter a phone number  and send a dial command to the modem.

Send a hang up command to their modem.

Options Menu

Set PC COM port and parameters for communication.

Specify modem settings, such as initialization strings, dial strings, etc.

Set a grid to be display on the computer monitor to aid in positioning.

Modify the downloadable font (256 characters which can be  edited or changed).

Configure the UniNET network.
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Overview A completed project file (*.PRJ) contains all the information needed to display your
page images and controller data values.  The panel hardware handles the
communications to transfer data to and from the controller.
Instead of writing a program in BASIC or C, use Designer to create one or more
display pages that control your application.  The multiple page capability allows
any application to be divided into as many pages as you want (depending only on
the size of your target system memory).  Create display pages quickly and easily
by using either the pull–down menus or the icons from Designer’s ToolBelt and
Extra ToolBelt.
Save completed project files to PC disk.  To update a project, either open the
project file from disk or connect the PC and panel and upload the existing project
file.  (The panel must be in Configuration Mode  to communicate with the PC.)

Create a Project File
When Designer starts, a blank project page is ready for editing.  A new project
may also be created by selecting “File→New” from the File menu (or click the
appropriate icon in the ToolBelt).  When selected, the current configuration
parameters (for the controller and the panel) are used with the new project.  The
latest configuration is saved and used the next time Designer is started.
When switching between two projects that use different configurations, the latest
project opened overrides the previous and becomes the new configuration values
for Designer.  To prevent accidental reset of the configuration parameters, you will
be prompted to confirm the New operation if there are pending modifications that
have not been saved. (Figure 2-1).

Figure 2-1  Save Project File Menu

If Yes is selected, you are prompted to enter the filename (if this is the first time
the project file has been saved) and the project file will be saved to disk.  If No is
selected, the changes will be lost.  Pressing Cancel will return to the current
project.

Identifying a Project File
There are two ways to identify a project file.  First, give the project file a descriptive
name when saving the file to disk (Figure 2-2).  You can recognize files quickly
without opening them, but is often not sufficient.  Selecting “Project→Application
Name” allows you to add a forty character description to a project file.  This
information is stored in the project file and will appear on all printed documents
produced by Designer.

Figure 2-2
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Opening Existing Project Files
To open an existing project, select File→Open menu (or click the icon in the
ToolBelt).  The dialog box shown in Figure 2–3 will appear.  Enter the name of the
file to be loaded, or use the list box to select from the existing files.  If the
extension is not specified, ”.PRJ” is assumed.

Figure 2-3  

Saving a Project File
To save a project, select File→Save (or click on the icon in the ToolBelt).  The
cursor is momentarily replaced by an hourglass while the file is being saved.  If the
application has not been named, the Save As dialog box will appear.  This dialog
box can also be used to save your project under a different name.  The Save As
dialog box shows the current directory path and the current filename.  A new name
and path may be entered.  If the extension is omitted, “.PRJ” is assumed.  If the
file already exists in the selected directory, you are prompted to confirm the Save
As operation before overwriting the existing file.

Figure 2-4  
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Get Panel Resources
Before you begin a project, the displays’ physical screen size and it’s type (backlit
LCD, vacuum fluorescent, electroluminescent, passive color) must be specified.
Failure to do this may result in the loss of text and data whenever you attempt to
download the project file into the panel.
The Get Panel Resources option automatically configures the software for the
panel.  The following list of steps illustrates how to use this feature.

1. The Panel must be connected to the PC with a CA1 or CA2 cable.
2. Connect the correct cable to the PC COM port.
3. Put the panel in Configuration Mode by holding down the ENTER key for

a few seconds.  When the Panel Command Menu appears, use the
cursor keys to highlight the Configuration option and then press ENTER.

Note: The panel must be in Configuration Mode to communicate with the PC.
4. Select “Transfers→Get Panel Resources” (or click the icon in the Extra

ToolBelt).
5. Select Yes to copy the panel resources into the current project file.  This

transfers the panel size and type automatically from the panel’s memory
and updates the Designer display.

You can manually configure by selecting “Project→Panel Setup”.  See “Panel
Setup” discussed later in this section.

Select Controller Driver
Designer offers support for Baldor controllers.  Select Project→Change Controller
Driver, then select the control family that they is installed.  Whenever a project file
is saved, Designer stores the selected driver type in the project file.

Figure 2-5  
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Panel Setup Select Project→Panel Setup from the main menu. The dialog box of Figure 2-6 is
displayed.  Use the pull down menu to select the Panel Model of the HMI panel
being used.  If memory has been added, select the memory size from the Panel
Memory pull down menu.

Figure 2-6  Panel Model  

Select the Settings tab.  Options are displayed as boxes and you can select or
deselect the option by clicking on the box.  Check marked items cannot be
changed.

Figure 2-7  Panel Settings 
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Select the Passthrough tab.  Most applications use Hardware Mode. Select the
Remote Hardware Mode (only if a modem is to be used).  For Remote, the
communication parameters you set here need to match the communication
parameters of your modem.  Once you have everything configured, you can use a
terminal emulation program on your PC to dial up the modem and access the
panel.

Figure 2-8  Passthrough Settings 

Modem Configuration (PC)
The following commands are necessary for the modem that is attached to the local
end (the PC that is running Designer).
AT  &D0  &K0  &Q0  &W  &Y
Term Explanation
&D0 DTR is ignored (according to &Q setting)
&K0 Disable flow control
&Q0 Direct asynchronous operation
&W Stores setting in profile 0
&Y Profile 0 is loaded on power up

Modem Configuration (HMI Panel)
The following commands are necessary for the modem that is attached to the
remote end (the HMI panel).
AT  &D0  %C0  &K0  &Q0  S0=1  &W  &Y
Term Description
&D0 DTR is ignored
%C0 Disable data compression
&K0 Disable flow control
&Q0 Direct asynchronous operation
S0=1 Auto answer after 1 ring
&W Stores setting in profile 0
&Y Profile 0 is loaded on power up
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When remote pass through is configured, a new entry is available in the Transfers
menu.  This new entry is called “Transfers→Start remote pass–through”.  This
entry allows you to select one of three pass through commands: Go to
Configuration Mode, Start Pass through and Stop Pass through.
When pass through mode is activated, the panel does not communicate with the
controller and the dynamic data displayed on the screen may no longer be correct.
A control variable named Passthrough Status informs you that pass through is
active.  This variable has two values; zero = pass through not active, one = pass
through is active.

Select the Miscellaneous tab.  Click the boxes to select or deselect a setting.
Figure 2-9  Miscellaneous Settings 

• Display selected page on communication error.  This is the page number
of the project file the panel will go to during a communication error.

• Timeout for panel command menu display.  In panel command menu,
this is the period of time the panel will wait for a keystroke before it
returns to normal operation.

• Timeout for data entry.  In data entry, this is the period of time the panel
will wait for a keystroke before it returns to normal operation.

• Timeout for field selection during data entry.  In data entry, this is the
period of time the panel will wait for a field selection to be made before it
returns to normal operation.

• LCD Screen Saver.  Turn On/Off the back lighting when no keys or
touchcells have been pressed for a certain amount of time.

• Panel Upload Protection.  Enter a password that must be used before an
upload can be accepted by the panel.
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Select Font Select a new font by: click on the down arrow at the right of the font window, select
the appropriate icon from the Extra ToolBelt, or choose  Project→Select Font
menu.  A drop–down list will appear showing the available fonts.  Select the font to
be used and click OK button to confirm the change.  Existing text on the current
page will change to reflect the new selection.  Any future text additions will also
appear in the newly selected font.  Selecting a new font for an existing project can
alter any special characters, message fields, and bargraphs that are contained in
the project file.  New fonts can be created with the font editor.

Figure 2-10  

The Font Size buttons are used to change the character size the text or variable
field.  Regular characters are simply a single character.  Double characters are
twice the size of a regular character (2x2).  Large characters are four times the
size of a regular character (4x4).  Extra large characters are eight times the size of
a regular character (8x8).
Note: It is possible to enlarge the font size only for those panels that are capable

of graphics.

Controller Setup If CANopen is used, select Project→Controller Setup and the setup the NodeID
and Baud Rate.

Figure 2-11  
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Printing From the Panel
Select “Project→Report on Panel Printer→Printer Setup” to define the serial
printer device driver and communication parameters.  It is possible to print a report
by configuring a key or touchcell to print a report, or to request a printout by using
the Interlock Mailbox.
The dialog box is shown in Figure 2-12.  Choose the printer you are using and set
the communication parameters.  If you use a printer that is not listed, use the
Add… button to add a new printer to the list of available printers.  Another dialog
box is displayed to define the parameters for the new printer.  Similarly, you can
use the Edit… button to redefine the parameters for the printer.
Note: If you print reports, the paper height should be defined before the report is

defined.  If you change the paper height and reports are already defined,
the report layouts will not automatically be rearranged.

Figure 2-12  Printer Setup
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Reports A report is a collection of pages of the project file (or parts of project file pages).
Each report is divided into two parts.  One is a common part, such as the header
and footer.  These are common to each page of the report.  The second is the
display page that is the body of the report.
To define a report, select “Project→Report on Panel Printer→Reports”.  The dialog
box of Figure 2-13 is then displayed.

Figure 2-13  

You can add a report by selecting the New button and giving the report a name.
All of the pages of your project file will be shown within the Available pages box.
To add a page to the current report, select the page from within Available pages
and click on the “<– Add” button.  Doing so will place the page name into the
Report pages box.  To add all of the pages of your project file to a report, select
the “<< Add All” button.
Similarly, to remove a page from the current report, select the page name from
within the Report pages box and click on the “Remove –>” button.  To remove all
of the pages from the report, click on the “Remove All >>” button.  To print a
portion of a page, selecting the page in the Report pages box and press the
Properties button.  The dialog box is shown in Figure 2-14.
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Figure 2-14  

Select the Advanced button of Figure 2-13, to set the following parameters that
are common for every page in the report.  The dialog box is shown in Figure 2-15.

•  Wrapping – If wrap lines is selected and a line is longer than the width of
the page, it will be printed on the next line.  If wrap lines is not selected
and a line is longer than the width of the page, it will be truncated.

•  The Page separator is a character that is optionally defined as a
place–holder for empty lines in the printed page.

•  Packing – If the page width is longer than the display width, you can print
two or more rows on a single line.

•  The field font specifies the font to use when a font has not been
specified in the definition dialog box (Figure 2-14).

•  Non–printable characters can be printed as blanks, asterisks, or with
downloadable fonts.  The downloadable options are grayed out if not
supported by the printer.

•  Display attributes can be transformed into another printer attribute, such
as normal, underlined, bold or italicized.

•  Condensed or Enlarged Mode Printing
Figure 2-15  
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Header/Footer Definition
The remaining two buttons in Figure 2-13 are the Header and Footer.  The
structure of the header and the footer are the same.  (Figure 2-16).
Specify the height of the header/footer, the fields that are inserted into the
header/footer, where they are inserted at and how they are positioned.  Usable
fields are: time and date, the page number, the report name and a label (which
allows you to enter static text).

Figure 2-16  

Printing a Report
Print a report in one of three different ways:

•  With a macro associated with a function key or a touchcell.  In the
Keyboard Macro Editor, there is a macro called Print Report.  When
selected a dialog box is displayed to allow a report to be printed
whenever this key (or touchcell) is pressed.

•  Cyclically at a specified time.  Print any report cyclically in two different
modes:  At a specific time each day or after an interval of time.  The
dialog box shown in Figure 2-17 allows you to define these
characteristics.  This dialog box is chosen be selecting “Project→Report
on Panel Printer→Triggers”.

Figure 2-17  
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•  From a PLC request issued through the Interlock Mailbox. There are two
Mailbox commands for this procedure.

Start Report Printout:
Command Word:    113
Parameter 0: Report Number
Responses: 0 = OK

1 = Error, printer process already active (if START command is issued more
than once.
Error, printer process already inactive (if CANCEL command    is issued
more than once)

2 = Error, illegal report number
3 = Error, activation queue is full

Stop Report Printout:
Command Word:    114
Parameter 0: None required
Responses: 0 = OK

1 = Error, printer process already inactive
Note: It is possible to start printing of more than one report.  Up to 10 printer

requests are stored in a FIFO (first in first out) buffer.

Printer Device Driver Parameters
Several print device drivers are supported by the Designer program.

•  ALFAPANEL.PRN – Driver for AlfaPanel printer from Edue Italia
•  IBMPRO.PRN – Driver for the IBM Proprinter (dot matrix)
•  HPLJ40.PRN & HPLJ80.PRN – Drivers for the HP LaserJet printer; the

first one for use with a 40 column operator interface panel and the
second one for use with an 80 column operator interface panel.

•  HP LaserJet III (or HP laser compatible printer)  The escape sequences
given in this section have been tested with:
•  HP LaserJet III;
•  HP LaserJet IV;

The list of escape sequences for text and graphic control (for HP) is given in Table
2-1.  The printer control code is 0.
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The ratio of the character width in text and graphic mode depends on the
resolution of the graphical printout in the following way:

Table 2-1
Command Sequence (decimal codes)
Initial Settings See note�

• reset printer
• set draft mode
• set letter quality mode

27 69
27 40 115 49 81
27 40 115 50 81

BOLD set 27 40 115 51 66

BOLD clear 27 40 115 48 66

ITALIC set 27 40 115 49 83

ITALIC clear 27 40 115 48 83

UNDERLINE set 27 38 100 49 68

UNDERLINE clear 27 38 100 64

CONDENSED set 27 40 115 50 48 72

CONDENSED clear 27 40 115 49 48 72

ENLARGED set 27 40 115 53 72

ENLARGED clear 27 40 115 49 48 72

Graphic mode
27 42 48 65 27 42 116 [resolution]� 82 27 42 114 49
85 27 42 98 [line length]� 87

75 dpi [resolution]=55 53

150 dpi [resolution]=49 53 48

300 dpi [resolution]=51 48 48

600 dpi� [resolution]=54 48 48

Graphic LF See note�

�  You may use any combination of these escape sequences.
�  These bytes specify resolution specified with 2 or 3 bytes see Table 2-2.
�  Line length depends upon  the width and quality of the font.
�  Allowed for HP LaserJet V and higher versions.
�  For HP PCL, it is not necessary to insert a new line separately since the

sequence that begins a new graphical line forces starting at a new line.
Table 2-2

Resolution (dots per inch) Ratio
75 1
150 2
300 4
600 8
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The line length depends on the following:
•  Width of the page being printed.  When printing pages with a maximum

of 40 columns, one line contains a fixed number of 60 bytes.  In the case
of an 80 column page, one line contains a fixed number of 100 bytes.

•  Line length varies with raster image quality.  When raster quality is
normal, line lengths have the values mentioned above.  As raster image
quality is increased, line length is doubled for each level, as it is shown
in Table 2-3.

Table 2-3
WIDTH OF THE SLIDE

Rasterization Level 40 80
LOW (1) 60 100

NORMAL (2) 120 200
HIGH (3) 240 400

IBM Proprinter (or IBM matrix compatible printer)
The escape sequences defined in this section have been tested with:

•  Epson LQ–400
The list of escape sequences for text and graphic control is given in Table 2-4.

Table 2-4
Command Sequence (decimal codes)
Initial Settings 27 64 27 77 27 120 0 27 107 2

BOLD set 27 69

BOLD clear 27 70

ITALIC set 27 52

ITALIC clear 27 53

UNDERLINE set 27 71

UNDERLINE clear 27 72

CONDENSED set 27 103

CONDENSED clear 27 77

ENLARGED set 27 80

ENLARGED clear 27 77

Graphic mode See note

60 dpi 27 42 0 8 0

90 dpi 27 42 6 8 0

120 dpi 27 42 1 8 0

240 dpi 27 42 3 8 0

Graphic LF 13 27 74 24

Font n See note

The ratio of the character width in the text and graphic mode depends on the
resolution as shown in Table 2-5.
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Table 2-5
Resolution (dots per inch) Ratio

60 1
90 3:2
120 4
240 8

The length of the graphical data block is always set to the value 8, regardless of
the display width.  In this case, the data block width is specified with the last two
bytes in the sequence that starts graphic mode.  The length is specified with the
equation a + 256 * b, where a is the 4th byte in the sequence and b is 5th number
in the sequence.  Both numbers are integers in the range of 0 to 255.  The
structure of the sequence can be different in the case of different Proprinter
compatible printers.

AlfaPanel Printer
The escape sequences described in this section have been tested with:

•  AlfaPanel 2
The list of escape sequences for text and graphic control is given in Table 2-6.
The printer control code is 2, and the ratio of the character width in the text and
graphic mode should be set to 1.

Table 2-6
Command Sequence (decimal codes)
Initial Settings

normal writing
upside down writing

27 78
27 82

ENLARGED set 03
ENLARGED clear 00
Graphic Mode 17
Graphic LF 13
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Triggers allows you to specify when a report is to be printed.   Select
“Project→Panel Printer→Triggers”.  A dialog box (Figure 2-18) will appear.  Select
from cyclic, which will print the report at a certain time, or every day. It is also
possible to print a report by using a function key or touchcell programmed via the
Keyboard Macro Editor, or by having the PLC issue a print request by using the
Interlock Mailbox.

Figure 2-18  Triggers

Memory Used by Project File
Determine how much memory is used by the current project file by selecting
“Project menu→Memory Use”.  A dialog box (Figure 2-19) will appear that
contains information on the amount of memory that is used by the project file, how
many bytes of Recipe data are contained within the project file and the amount of
memory used by the graphic information (bitmaps and touchcells) in the project
file.

Figure 2-19  Memory Used
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Controller references are those data items that the Designer software uses to
display information from the controller.  These data items are in the form of
numeric fields (which are displayed in numeric format or in ASCII format),
bargraphs, message fields, and attributes.

Numeric Fields
1. Create a numeric field in the page of the project file.  There are four

ways to create a numeric field.
a. Position the cursor at the desired location and click the Controller

Data icon in the Extra ToolBelt.  Then, either double click the left
mouse button or single click the right mouse button on the location
where you want the field.

b. Position the cursor on the desired location and select “Edit→Data
Field Type→Numeric/ASCII” at the main menu.

c. Position the cursor on the desired location and click the Numeric
Field icon in the ToolBelt.

d. Click and drag an area in which the field is to be located, then click
the Numeric Field icon in the ToolBelt.  This method will
automatically set the height and width of the field.

2. When the numeric field is created, a dialog box (Figure 3-1) is displayed.
Figure 3-1  
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3. The upper portion of the dialog box is the PLC Reference section.  The
data type, data format, and address are configured for the selected
controller.

4. The lower portion of this dialog box is not driver specific.  This area is
used to format the data for display.  The following items can be
configured:
a. Display format
b. Data access (read only, read/write field)
c. Data scaling
d. Numeric base
e. Field dimensions
f. Min. & max. values (read/write field only)

Bargraphs
1. There are four ways to create a bargraph field on the project file page.

a. Click and drag the mouse to select the size and location of the
bargraph, followed by selecting the Bargraph Field icon located in
the ToolBelt.

b. Position the cursor at the location the bargraph is to begin and
select the Bargraph Field icon from the ToolBelt.

c. Position the cursor at the location the field is to begin and select
“Edit→Data Field Type→Bargraph” at the main menu.

d. A final method is to click and drag the mouse to select the size and
location of the bargraph and then select Data Field Type – Bargraph
from the Edit menu.  Regardless of the method, the define field
dialog box will automatically appear, allowing you to select an
address in which to dynamically fix the bargraph.

2. When the field is created, a dialog box (Figure 3-2) is displayed.  The
address that was chosen in the PLC Reference section will be
dynamically linked to the bargraph.  In other words, the value of the
register will correspond to the fill level of the bargraph.  The maximum
value of the field is represented when the bargraph is full.  Likewise, the
minimum value is represented when the bargraph is empty.

3. Figure 3-3 represents a bargraph with a field width of 20, a field height of
3, a minimum value of 0, and a maximum value of 100.  The minimum
value is the point at which the bargraph is empty.  Likewise, the
maximum value is the point at which the bargraph is full.

The border around the bargraph can be drawn by highlighting the area
around the bargraph field and then selecting Rectangles & Symbols from
the Edit menu.  Doing so will bring up a dialog box that contains two
different borders that can be placed around the bargraph.  The Designer
software considers this border as a graphic.  Therefore, this feature can
only be accessed for panels that support graphics.
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Figure 3-2  

Figure 3-3



3-4  Receiving & Installation MN1271

Message Fields Message fields are used instead of numerical values to inform you that an event is
occurring.  For example, assume the message “Voltage too high“ is attached to
the value 32.  When the value of the register in the controller reaches 32, the
message will be displayed.  In this manner, a text message is displayed on the
panel, which is often more beneficial and meaningful to the operator than
displaying a numerical value.
Note: The maximum number of messages that can be displayed is 1024.

1. A message field is created in one of two ways.
a. Click and drag the mouse to highlight the area in which the

message field is to be placed and then select the Text Message
Field icon from the ToolBelt.

b. Place the cursor at the desired screen location and select
“Edit→Data Field Type→Message” at the main menu.

2. When the message field is created, a dialog box (Figure 3-4) is
displayed.  The number of messages to be displayed is set by the values
for the minimum and maximum values.  For example, if the message is
fixed to a bit, the field will have a maximum of two messages.  The width
of the field is equivalent to the maximum number of characters the
message field can contain.  When the parameter values are set, click the
“Edit Message” button to begin entering messages for the different data
values. The dialog box of Figure 3-5 is displayed.

Figure 3-4  
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3. To select a message to edit, click the left mouse button on the desired
value and begin typing the message.

Figure 3-5  

4. Special characters may be added to the message, click the Spec chars
button.  This will display a dialog box (Figure 3-6). Select the
character(s) to be used (double click on them or by single clicking on
them and pressing Select).  After confirming the operation, the
characters will appear in the last position the cursor was in before
entering the special characters dialog box.

Figure 3-6  

Note: WindowsTM features cut, copy, and paste are also available for editing
messages.  If you have several messages that are similar, you can Copy
and Paste messages then make any necessary changes.

If you want to copy several messages that are in successive order, click the
first one and drag the mouse down until the last one is highlighted and
release the mouse button.  If you want to copy several messages that are
not in successive order, hold down the Ctrl key, click each of the messages
that you want to copy, and release the Ctrl key. 

Click the Copy icon to copy the messages into Windows’ Clipboard.
Highlight the message number where you want to paste the first message
and click Paste.  The messages are copied to their new locations.
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Attributes Attributes allow an area of the screen to be highlighted, image reversed, or
blinking.

1. To create an attribute  field, click and drag the mouse to select the area
in which the attribute is to be displayed.

2. Select “Edit→Data Field Type→Attribute” at the main menu or click the
appropriate icon in the ToolBelt.

3. When the attribute field is created, a dialog box (Figure 3-7) is displayed.
Figure 3-7  

4. If static is selected, any combination of the blink, reverse, and highlight
attributes may be used.

5. If dynamic is selected, the screen attribute will be fixed to a value of a
word or bit in the controller.  The address of the controller’s memory
location is entered in the upper portion of the dialog box.

Notes: (Dynamic Attributes:)
1. If the attribute is referenced to a word, the attribute is dependent upon

the three least significant bits in the controller’s memory location (see
Table 3-1).

2. If the attribute is referenced to a bit, there will be no attribute displayed
when the bit has the value of 0.  The blink attribute will be displayed
whenever the bit has a value of 1.

3. Not all attributes are supported on every panel.
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Table 3-1
Decimal Value Bit 2 Bit 1 Bit 0 Attribute

0 0 0 0 Normal

1 0 0 1 Blinking

2 0 1 0 Highlight

4 1 0 0 Reverse

Color Attributes All color panels support a dynamic attribute field that allows dynamic control of the
color of an area on the display.  The color attributes are an extension of the
existing monochrome dynamic attributes (blink, reverse and highlight).
The word in the controller memory referenced by the dynamic attribute is defined
in Table 3-2.

Table 3-2
Bit 15 14 13 12 11 10 9 8 7 6 5 4 3 2 1 0

F0–F3 B0–B3 C M0–M2
Foreground color Background color Monochrome

attribute

C (bit 3 in Table 3-2) is the bit that enables the color attribute mode:

C Color attributes
0 Disabled
1 Enabled

The Color attributes are defined in Table 3-3.
Table 3-3

Bit
3 2 1 0

Numeric value Color

0 0 0 0 0 Black
0 0 0 1 1 Dark Red
0 0 1 0 2 Dark Green
0 0 1 1 3 Dark Yellow
0 1 0 0 4 Dark Blue
0 1 0 1 5 Dark Magenta
0 1 1 0 6 Dark Cyan
0 1 1 1 7 Dark Gray
1 0 0 0 8 Light Gray
1 0 0 1 9 Red
1 0 1 0 10 Green
1 0 1 1 11 Yellow
1 1 0 0 12 Blue
1 1 0 1 13 Magenta
1 1 1 0 14 Cyan
1 1 1 1 15 White

Note: The foreground and the background colors are set independently.
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Scaling Data that is displayed or sent to the controller can be scaled.  Scaling is done
within the define field dialog box (see Figure 3-8). 

Figure 3-8 

Another feature is the ability to use fixed point numbers.  This allows decimal
values to be displayed on the panel.  Simply select the Fixed Point radio button
and enter the number of decimal places to be displayed in the Placement box (see
Figure 3-8).  Keep in mind that the decimal point will occupy one position in the
field (i.e., a field with a width of four and a placement of 1 can display at most the
number 99.9).

The Scaling Equation
The scaling equation is defined as:

�� ��

��
�
� � �� �

Where:
Y = Scaled value displayed
X = Controller data value
A,B,C = Scaling operators – these are the three entry boxes located within 

the scaling equation.
There are two important concepts to understand about scaling.

1. First and foremost, the scaling operators (A, B, and C) are 16 bit
integers.  Internal calculations are done using 32 bit arithmetic, which
allows the panel to report a more precise result than if it were using only
16 bit arithmetic.

2. Secondly, the maximum and minimum fields refer to the scaled value,
not the value that is in the controller.

Example 1 This example converts Celsius temperature received from the controller to
Fahrenheit temperature for display on the panel.

1. Create a numeric field and reference it to the address in the controller
that is reporting the temperature.  For this example, assume the address
is COMMS1.  When the numeric field is created, the define field dialog
box (Figure 3-9) is displayed.

2. To convert a value from Celsius to Fahrenheit, multiply the Celsius
temperature by 9/5 and add 32 to the result.

3. Consider the scaling equation again : Y = (A/B) * X + C.   If the values
shown are entered into the numeric field, the display is in Fahrenheit.
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Figure 3-9  

Example 2 A controller memory location can range in value from 0 to 4095.  It is desired to
display that value as a percentage of the maximum possible value on the panel.

1. Create a numeric field and reference it to the address in the controller
that is reporting the value.  For this example, the address is COMMS1.
When the numeric field is created, the define field dialog box (Figure
3-10) is displayed.

2. To display the actual controller value as a percentage of the maximum
value, scaling is needed.  If the actual value in the controller is 0, then
the panel should display a 0.  If the actual value in the controller is 4095,
the panel should display a 100.

3. This is accomplished by dividing the value in the controller by the
maximum possible value and multiply this result by 100.  Consider the
scaling equation again : Y = (A/B) * X + C.   If the values shown are
entered into the numeric field, the display is in percentage.
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Figure 3-10  

Indexed Addressing
Indexed addressing mode allows many controller memory locations to be
referenced from a single numeric field.  This allows you to monitor the values of
many memory locations while using only one field.  This feature is accessed either
by clicking on the appropriate icon in the Extra ToolBelt or by selecting
“Edit→Indexed Addressing Mode” at the main menu.
Example
Assume a user has a plant in which industrial equipment is washed.  There are three
stages of the wash process.  You want to monitor the water temperature, the water
pressure, the amount of time the equipment is in a particular stage, and the stage the
process is in.  (Without pressing a key on the panel.)  The controller memory locations
and their contents for this example are as follows:
COMMS1 – Temperature in Stage 1 (ranges between 0 and 9999)
COMMS2 – Temperature in Stage 2 (ranges between 0 and 9999)
COMMS3 – Temperature in Stage 3 (ranges between 0 and 9999)
COMMS4 – Pressure in Stage 1 (ranges between 0 and 9999)
COMMS5 – Pressure in Stage 2 (ranges between 0 and 9999)
COMMS6 – Pressure in Stage 3 (ranges between 0 and 9999)
COMMS7 – Time in Stage 1 (ranges between 0 and 9999)
COMMS8 – Time in Stage 2 (ranges between 0 and 9999)
COMMS9 – Time in Stage 3 (ranges between 0 and 9999)
COMMS10 – The stage the process is currently in (ranges between 1 and 3)
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The numeric values are written into the controller by the machine and are
changing constantly.  Note that the memory locations are controller specific.
Those chosen in the example are done so to more easily explain the procedure of
using indexed addressing.
This example is divided into four basic steps:
1.  Creating the “Temperature” indexed addressing field,
2.  Creating the “Pressure” indexed addressing field,
3.  Creating the “Time” indexed addressing field, and
4.  Creating the “Stage” numeric field.
These fields are all related.  The values that are displayed within each are
dependent upon the stage of the process.  The indexed fields will be addressed so
that whenever the field number is written to the “Stage” numeric field location
(COMMS10), the corresponding information will be displayed in each of the
indexed fields.  (For example, when a value of 2 is written into COMMS10, each of
the indexed fields will display the corresponding data: the temperature in stage 2,
the pressure in stage 2, and the amount of time spent in stage 2.)
Creating the Temperature Indexed Field

1. Select “Edit→Indexed Addressing Mode” at the main menu or click the
appropriate icon in the ToolBelt.  The addressing mode is set to indexed.

2. Now create a numeric field on the screen where the process temperature
information is to be displayed.  Refer to creating a numeric field.

3. When the numeric field is created, a dialog box (Figure 3-10) is displayed.
4. The top portion of this dialog box is controller specific.  The address is

COMMS10 and is entered in this area of the dialog box.  Since the
values written into this memory location are between 1 and 3, enter
these as the minimum value and maximum value, respectively.  This
field needs to be a read only field, because the controller is set up to
write the numeric value of the current state (either a 1, 2, or 3) into this
location.
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Creating the Pressure Indexed Field and the Time Indexed Field
1. Select “Edit→Indexed Addressing Mode” at the main menu or click the

appropriate icon in the ToolBelt.  The addressing mode is set to indexed.
2. Now create a numeric field on the screen where the process temperature

information is to be displayed.  Refer to creating a numeric field.
3. When the numeric field is created, a dialog box (Figure NO TAG) is

displayed.
4. The top portion of this dialog box is controller specific.  The address is

COMMS10 is entered in this area of the dialog box.  Since the values
written into this memory location are between 1 and 3, enter these as the
minimum value and maximum value, respectively.  This field needs to be
a read only field, because the controller is set up to write the numeric
value of the current state (either a 1, 2, or 3) into this location.

5. When creating the pressure indexed field, click the Indexed button to
display a dialog box (Figure 3-11).  The value of 1 is written to COMMS4.
Likewise, the value of 2 should be referenced to COMMS5, and the
value of 3 should be referenced to COMMS6.)

Figure 3-11  

6. When creating the time indexed field, click the Indexed button to display
a dialog box (Figure 3-12).  The value of 1 is written to COMMS7.
Likewise, the value of 2 should be referenced to COMMS8, and the
value of 3 should be referenced to COMMS9.)

Figure 3-12  
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Creating the Stage Numeric Field
1. To create a numeric field, indexed addressing mode must be turned off.

Select “Edit→Indexed Addressing Mode” at the main menu or click the
appropriate icon in the ToolBelt.

2. Now simply create a numeric field and address it to COMMS10.  The
dialog box is shown in Figure 3-13.  Since this field is only going to
display a single digit, the field width has been reduced to 1.

Note: If it is desirable to be able to edit the stage of the process, that numeric field
could have been created as a read/write field instead of a read only field.

Figure 3-13
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The Finished Project
A dialog box representing what the finished setup may look like is shown in Figure
3-14.

Figure 3-14  
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The Keyboard Macro Editor allows the association of certain functions with keys or
touchcells on a panel.  This feature may be accessed by selecting
“Project→Keyboard Macro Editor” at the main menu or click the appropriate icon in
the Extra ToolBelt.  The Keyboard Macro Editor dialog box is shown in Figure 4-1.
Each of the available functions are called elementary macro commands.  They are
accessed by clicking the proper icon in the Commands toolbar from within the
Keyboard Macro Editor.  Advanced commands, called complex macro commands,
are composed of two or more elementary macro commands.  For example, Go to
page 2 is an elementary macro command.  Select field 5, Begin data entry is a
complex macro command composed of two elementary commands.  Complex
macro commands function by executing each of the elementary macro commands
in the sequence in which they were entered.

Keyboard Macro Editor Dialog Box
Figure 4-1

At the top of the Keyboard Macro Editor dialog box is a scrollable toolbar of panel
keys that are available for programming.  Use the arrow keys located beneath the
toolbar to maneuver through the panel keys.  Not all keys are available on every
panel.  Select a key by clicking on it with the left mouse button.  The selected key
is displayed in a lighter color than the other keys.
Below the toolbar of panel keys are the Key states radio buttons. The state is
selected by simply clicking on the proper radio button.  You can program a key to
be active whenever it is pressed, released, or held down. “Held down“ is referred
to as fast autorepeat and is useful when dramatically changing the value of a
register.  For example, the F1 key is programmed to increment a register by a
value of 1.  To change the value from 20 to 200, you would have to press the F1
key 180 times if it were programmed in the pressed state.  However, by
programming the key in the fast autorepeat key state, you can press and hold the
key until it reaches the value of 200.
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8 index tabs are shown under the Key states radio buttons.  Each index tab
represents an operating mode of the panel.  The selected operating mode is
indicated by the index tab being displayed in the foreground with respect to the
other tabs.  The small circle located in the upper left–hand corner of each index
tab is a program indicator.  If the indicator is red, a key is programmed in that
particular operating mode.  Similarly, if the indicator is yellow, no keys are
programmed in that particular operating mode.
Under the index tabs is the Commands toolbar.  Each elementary macro
command is represented by an icon in this toolbar.  If there is not enough room to
display all of the icons, left and right arrow keys will be present at the ends of the
toolbar, allowing you to scroll to access all of the elementary macro commands
available for a particular mode of operation.  When a command is selected, it is
displayed in the list box at the bottom left side of the dialog box.  Commands are
inserted, appended, and deleted by using the buttons located to the right of the list
box.

Macro Editor Modes
The Keyboard Macro Editor has eight operating modes. Not all commands are
available in each operating mode.  The Keyboard Macro Editor will only display
those macros that are available for the selected mode.
The following operation modes are available:
• Global – this is used for the global setup of toggle keys.
• All Pages – macros defined here are active on every page of the 

  project file.
• Page n – macros defined here are active only when the panel 

  is on page n (where n is a page number).
• Data Entry – macros defined here are active only when the panel

  is in Data Entry Mode.
• Alarms – macros defined here are active only when the panel 

  is in Alarm Mode.
• Command Menu – macros defined here are active only when the panel 

  is in the Panel Command Menu.
• Event List – macros defined here are active only when the panel 

  is in the Event List Mode.
• Time / Date – macros defined here are active only when the panel 

   is in the Time and Date Mode.

All Pages Mode and Page n Mode
The relationship between the All Pages mode and Page n mode is particularly
important to understand.  A single key can be programmed in different operating
modes to perform different functions.  A macro programmed in All Pages mode is
active in all pages of the project.  A macro programmed in Page n mode is active
only when the panel is on “page n”.  A macro that is programmed in Page n mode
will override a macro that is programmed in All Pages mode only when the panel is
on page n.
For example, F1 is programmed to go to page 2 in All Pages mode and it is
programmed for begin data entry in Page n mode (say, page 5).  In this case, the
only time that the panel will go into Data Entry Mode when the F1 key is pressed is
when the panel is on page 5.  On all other pages of the project, pressing F1 will
display page 2.
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Elementary Macros
The elementary macro commands for each operating mode are described here.
The name of the macro is identical to the text that is displayed whenever you
move the cursor over the icon.

Global
Set toggle key – The key that is assigned to this elementary macro command will function like a

push–button toggle switch, changing the value (0 or 1) of the bit each time the key is activated.  You must
specify the control relay bit to be toggled.  Note that a key programmed in this mode will function as a
push–button toggle switch in all other modes as well.

All Pages
Go to page – Display a specific page.  The user is asked to input the page number.

Return to initial page – Display the page that was displayed before the “Go to page” macro command
was executed.

Password protect –  Allows the user to require that a password be entered before executing any
macros that follow.  The panel will not prompt the user to enter the password, rather the user must
enter the password by using the Password selection in the panel command menu.  If the password
is not active, the panel will simply not execute any macro commands that follow.  A dialog box to
specify which password(s) must be active (shown in Figure 4-2) is displayed.

Figure 4-2  

Show Alarm List –  Change to Alarm mode and display the currently active alarms.  This is designed to
be used when a user does not want the alarm list to appear every time there is an alarm active.
Rather, the user wants to be able to bring up the alarm list on demand.  This macro will work only if
there are active alarms.

Show Event List – Display all events currently stored in the event list.  This macro works only if there
are events in the list.

Printout on/off – Print the current page, the alarm list, or the event list.  This command turns the printer
On/Off.  If the printer is not printing, press this key to start printing.  Likewise, if the printer is printing,
press this key to stop printing.

Print Report – Print any of the reports that have been configured.

Scroll to line – Specify the page row that is to be considered the topmost row of the display.  Activating
this command will scroll the panel to the “new” topmost row.  This is useful when there are more
lines on a page than can be displayed.  This macro will function only when there are enough defined
lines to make the selected line the topmost line (for example, the user can not specify line 30 to be
the topmost line, if there are only 32 displayable lines).
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All Pages Continued
Select data entry field – Select the field they wish to edit.  This only selects the field.  To edit the field,

the user must begin data entry.  Note that fields are counted from left to right, top to bottom on the
panel.  Attributes, time data fields, date data fields and touchcells attached to the controller are
counted as fields.

Begin data entry – Place the panel in the Data Entry Mode.  The user may now select the field and
press ENTER to begin editing the value.

Data editing – Begin editing the value.  This operates like the ENTER key and should be used in a
complex macro command following begin data entry.

Data Entry Popup toggle – Used with a touchscreen panel to enable or disable the numeric keypad
displayed on the panel.   This command is mainly used to turn this keypad off.

Clear Event List – Clear all of the entries from the queue of events.

Write to Controller – Allows the user to write constant values to the controller memory.  The user is
prompted for the specific memory location, as well as the value to be written.

Toggle Relay – Allows the key to behave as a push–button toggle switch.  The user is prompted for the
controller bit to be toggled.

LED state – Set the state of any LED that is attached to the keys on the panel.  The LEDs can be set to
ON, OFF, BLINK, or DEFAULT.  The DEFAULT state is determined by the value of the LED bit in the
reserved data area (RDA).

Scroll up – Scroll the display up one line.

Scroll down – Scroll the display down one line.

Wait – Pause for a specified amount of time before executing the next macro command.  The time
entered for this command is in tenths of a second.

More – Display remaining tool Icons. (Scrolls to last Icons).

Step – Allows the user to increase or decrease the numeric value of a register.  The user may enter the
step size, as well as the minimum or maximum values the register is not to exceed.

Display Text – Allows the user to display a text message on the  panel.  The user is asked to enter the
row and column number at which the message is to be displayed.

Attribute – Allows the user to specify the display attribute of an area on the page.  These are reverse,
blink, and highlight.  The user is prompted for the row, column, width, and height of the area that the
attribute is to affect.

Recipe Control – Allows the user to perform different Recipe functions, including downloading a
particular parameter set, uploading a particular parameter set, and selecting a particular parameter
set.  The user must enter the page number and the parameter set that is to be affected.  Entering a 0
for either will cause the current page/parameter set to be chosen.

Passwords – This will request the user to enter a password.  If passwords are not defined in the
project, this command will have no effect.

Next page – Display the next page of the project, providing the user is not on the last page.

Previous page – Display the previous page of the project, providing the user is not on the first page.

Brighter display – Increases the brightness of a vacuum fluorescent display panel and the contrast of
an LCD display panel.

Dimmer display – Decreases the brightness of a vacuum fluorescent display panel and the contrast of
an LCD display panel.



Keyboard Macro Editor  4-5MN1271

All Pages Continued
Pass–through Mode – Enable or disable passthrough mode.  This is designed so the user can go

on–line with the controller without disconnecting any cables.

Control Variable Step – Increment or decrement a control variable field (such as parameter set select
or to change the language).

Go to Recipe Menu – This macro sets the Recipe Page for Selection and jumps to the specified page.
(Refer to Section 10 Recipes.)

Scroll Recipe Menu – Scroll the choices of the Recipe Menu field.  Use this macro command to choose
a new Recipe Parameter Set from the list. Positive values for the scroll step move the selection
down, negative values move the selection up.

Confirm Recipe Menu Selection – Accept the selected parameter set name and sets the current recipe
parameter set to the new value.  It can be assigned to a key with “Return to Initial Page” macro to
close the Recipe Menu page and return to the page jumped from.

Recipes and Events Backup –

Page 1  A macro programmed in Page n mode will be active only when the panel is on
“page n”.  A macro that is programmed in Page n mode will override a macro that
is programmed in All Pages mode only when the panel is on page n.

Data Entry
Next field – Position the cursor on the next read/write field.  Fields are counted left to right, top to

bottom.

Previous field – Position the cursor on the previous read/write field.

Field down – Position the cursor on the next read/write field directly below the currently selected field.
If the data fields are not aligned vertically, this command will have no effect.

Field up – Position the cursor on the next read/write field directly above the currently selected field.  If
the fields are not aligned vertically, this command has no effect.

Step – Increase or decrease the numeric value of a register.  The user may enter a step size, as well
as the minimum and maximum values for the register.

Confirm – This confirms the entered value and exits Data Entry Mode.

Cancel – This cancels the entered value and exits Data Entry Mode.

Erase – This will erase the text that has been entered in the data field.

Begin data entry – Place the panel in Data Entry Mode.  The user can now select the field and press
ENTER to begin editing the value.

Data editing – Allow the user to begin editing the value.  This operates like the ENTER key and should
be used in a complex macro command following begin data entry.

Write to Controller – Write values to the controller memory.  The user is prompted for the specific
memory location, as well as the value to be written.

Toggle Relay – Allows the key to behave as a push–button toggle switch.  The user is prompted for the
controller bit to be toggled.

Wait – Pause for a specified amount of time before executing the next macro command.  The time
entered for this command is in tenths of a second.

Control Variable Step – Increment or decrement a control variable field (such as parameter set select
or to change the language).
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Alarms
Write to Controller – Write values to the controller memory.  The user is prompted for the specific

memory location, as well as the value to be written.

Toggle Relay – Allows the key to behave as a push–button toggle switch.  The user is prompted for the
controller bit to be toggled.

Wait – Pause for a specified amount of time before executing the next macro command.  The time
entered for this command is in tenths of a second.

Page Mode – Return the panel to current page mode from alarm  mode.

Acknowledge alarm – This is used to acknowledge an active alarm.

Scroll up – Display the next alarm, assuming more than one alarm is active.

Scroll down – Display the previous alarm, assuming more than one alarm is active.

Print alarms – Print all active alarms.

Go to alarm page – If an alarm page has been specified for the currently active alarm, this macro
command will display that specified page.

Control Variable Step – Increment or decrement a control variable field (such as parameter set select
or to change the language).

Command Menu
Page Mode – Return the panel to current page mode.

Left – Positions the cursor on the next command to the left of the currently selected command.

Right – Positions the cursor on the next command to the right of the currently selected command.

Up –  Positions the cursor on the command directly above the currently selected command.

Down – Positions the cursor on the command directly below the currently selected command.

Confirm – Select the currently highlighted command (operates like the ENTER key).

Control Variable Step – Increment or decrement a control variable field (such as parameter set select
or to change the language).

Event List
Password protect –  Allows the user to require that a password be entered before executing any

macros that follow.  The panel will not prompt the user to enter the password, rather the user must
enter the password by using the Password selection in the panel command menu.  If the password
is not active, the panel will simply not execute any macro commands that follow.  A dialog box to
specify which password(s) must be active (shown in Figure 4-2) is displayed.

Clear Event List – Clear all of the entries from the queue of events.

Page Mode – Place the panel in current page mode.
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Event List Continued
Scroll up – Scroll up the event list one line.

Scroll down – Scroll down the event list one line.

Control Variable Step – Increment or decrement a control variable field (such as parameter set select
or to change the language).

Time / Date
Page Mode – Place the panel in current page mode.

Next field – Positions the cursor on the next read/write field.  Fields are counted left to right, top to
bottom.

Increment – Increments the selected field to the next value.

Decrement – Decrements the selected field to the next value.

Control Variable Step – Increment or decrement a control variable field (such as parameter set select
or to change the language).

Macro Example This example describes the steps necessary to create a simple macro.  The panel
must be in the Configuration Mode to communicate with the PC.

1. The Panel must be connected to the PC with a CA1 or CA2 cable.
2. Connect the correct cable to the PC COM port.
3. Put the panel in Configuration Mode by holding down the ENTER key for

a few seconds.  When the Panel Command Menu appears, use the
cursor keys to highlight the Configuration option and then press ENTER.

4. Start the Designer for WindowsTM software package.  Make sure that the
project file is set up to work with the panel you are using.  (Get Panel
Resources from the Transfers menu and click OK.)

5. Activate the Keyboard Macro Editor (select “Project→Keyboard Macro
Editor” or select the proper icon in the Extra Toolbelt).

6. At the Macro Editor dialog box, click the key you wish to assign a macro
to and click Key states to Pressed.  Click the All Pages index tab.  The
macro is now set to function whenever the key is pressed on any page of
the project.

7. Click the leftmost icon in the Commands toolbar.  This icon is the
elementary macro command Go to page.

8. Another dialog box will appear.  Enter the page number that the panel
should display when the key is pressed.  In this example, it is set to page
2.  Therefore, enter a 2 in this box and click OK.

9. The list box located at the bottom left  side of the Macro Editor dialog
box will list the defined macro.  Click OK to confirm the command and
return to the page editor workspace.

10. Type the text “Page 1” in the topmost row of the current page.
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11. Press the F7 key to create another page.  Press the Page Down button
on  the keyboard to move to this page.  Type the text “Page 2” in the
topmost row of this page.

12. Select Download from the Transfers menu.  The project file will be
downloaded to the panel.

13. When the download is completed, the panel will go into Operation Mode
and display the text “Page 1”.

14. Press the key to which the macro was assigned (in step 6).  The panel
displays the second page of the project, indicated by the text “Page 2”.

Tips & Techniques
1. Avoid writing a macro that consumes too much processing time and

degrades system performance.  Execution of the macro command
requires time.  While a macro command is being executed, any type of
keystroke on the panel will be queued and executed as soon as
possible.  This may lead to unexpected results if too many keys are
pressed before macro execution is complete.  An example of a macro
that might take a relatively long time to execute follows:
Go to page 1
Print page toggle
Wait 50 tenth(s) of a second
Go to page 2
Print page toggle
Wait 50 tenth(s) of a second
Go to page 3
Print page toggle
Wait 50 tenth(s) of a second
Go to page 4
Print page toggle
Wait 50 tenth(s) of a second
Go to page 5
Print page toggle

2. When using the macro command Attribute, the command will be written
to the specified screen location.  For example, assume a user has a 4
line panel and has a key programmed to assign an attribute of reverse to
the screen location of row 2, column 1, height of 1, width of 1.  Wherever
the user is at on the page, executing this macro will assign the reverse
attribute to the second displayed row on the panel.

3. Do not program the ENTER key.  Doing so may keep the user from
being able to get into Configuration Mode, confirming data entry, etc.

4. If the user decides to program the 0 numeric key, they may not be able
to edit values on a page where 0 is also used as the INSERT key.

5. If the user decides to program the arrow keys, they may lose the ability
to scroll between pages and/or numeric fields within the project.

6. A key can be programmed in both the pressed and released states.
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7. In general, macro commands that switch operating modes are not
valid! Programming a key to function in more than one operating mode
within a single macro command will not work.  For example, the following
macro command goes from Password Mode to Data Entry Mode to Page
Mode and will not work properly.
Enter Password
Begin Data Entry
Confirm Data Entry
Go to Page 7

Multiple Field Data Entry
This feature allows you to edit more than one field without having to exit Data
Entry Mode.  This feature cannot be implemented by using a touchcell.  A physical
panel key must be pressed.
To use this feature, create a macro key that is programmed as follows:

•  In the Pressed state, the key is programmed in All Pages Mode or Page
n Mode with the macro Begin Data Entry.

•  In the Released state, the key is programmed in Data Entry Mode and
perform the following elementary macro commands in sequence:
1)  Confirm Data Entry
2)  Begin Data Entry
3)  Go to Next Field
4)  Begin Editing Value

Example
To have F1 programmed for the Pressed state, do the following:

1. Select “Project→Keyboard Macro Editor” at the main menu (you can
also click on the Keyboard Macro Editor icon in the Extra ToolBelt).

2. Click the F1 icon at the top of the page.
3. Click the Pressed radio button beside Key states.
4. Click either All Pages or Page n, depending upon if you want this key to

function in all pages or on only one specific page.
5. Click the Begin Data Entry icon in the Commands toolbar (this icon

shows a hand pressing a key).
6. Click OK.

Figure 4-3 shows the Macro Editor dialog box after these steps have been
completed. To program the F1 key for the Released state, do the following:

1.  Enter the Keyboard Macro Editor.
2.  Click the F1 icon at the top of the page.
3.  Click the Released radio button beside Key states.
4.  Click the Data Entry index tab.
5.  Click the Confirm Data Entry icon in the Commands toolbar (this icon is

a green check mark).
6.  Click the Begin Data Entry icon in the Commands toolbar (this icon

shows a hand pressing a key).
7.  Click the Go To Next Field icon in the Commands toolbar (this icon has

of a yellow box with a crooked arrow pointing down to a white box).
8.  Click the Begin Editing Value icon in the Commands toolbar (this icon is

a small box with the numbers 1, 2, and 3 below it). Click OK.
Figure 4-4 shows the Macro Editor dialog box at the completion of these steps.
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Figure 4-3  

Figure 4-4

Using the Macro to Edit Multiple Fields
To use the macro that was just created, simply press the F1 key.  A read/write data
field will be selected.  This allows you to enter the value for that field.  Pressing F1
again will confirm your data entry and advance you to the next read/write field on
the page.  Repeat this process until all of the fields have been edited.  Pressing
the ENTER key will return the panel to normal operation.
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Defining Passwords
Eight levels of passwords are provided to control what each operator can do with
the panel.  Select Project→Passwords and the dialog box that shows these levels
is displayed, Figure 5-1.

Figure 5-1

The person having the highest level password (top row of Figure 5-1) has access
to all of the panel functions.  This is done to allow at least one person the ability to
change the project file contained within the panel.
Password protection is provided for the following:
CONF – Access the Configuration Mode.  Alter the project file and 

  download it  from the PC.
TIME – Access the Time & Date Mode.  Change the time and date

  information that is stored within the panel.
PAGE – Access Direct Page Selection Mode.  Access specific pages 

  of the project.
ACK – Acknowledge alarms.
PRINT – Request printouts.
ALOGI – Automatic login.  This is used to automatically login a 

   specified password whenever there is no valid password in the 
   system (e.g., when the panel goes from Configuration Mode to 
   Operation Mode, or when an incorrect password is entered.  This 
   option can only be assigned to one password and will work only if 
   there are no other valid passwords in the system.

ALOGO – Automatic logoff.  Automatically disable a specified password
    ten minutes after it has been entered.  The time is fixed 
   and can not be changed.

Data entry enable – Access Data Entry Mode for specific pages.  Edit any
   read/write fields on the specified pages.

If a checkbox is selected, the user has access to the pages (providing the correct
password is entered).  If an incorrect password is entered, asterisks are displayed
on the panel and the previous valid password is lost.
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Example
Assume three users have access to the operator panel.  User 1 has access to all
areas of the project.  User 2 is only allowed to acknowledge alarms and enter data
on pages 2, 3, and 4.  User 3 is able to enter data on all pages and is allowed into
Configuration Mode.  User 3 should be automatically logged off after 10 minutes.

1. Select “Project→Passwords”.  A dialog box like Figure 5–1 is displayed.
2. For User 1, click the top password box and enter the password for User

1.   (Full access to all areas).
3. For User 2, click the second password box and enter the password for

User 2.  To allow access to acknowledge alarms, click on the ACK box.
Doing so should place a check mark in the box.  Allowing data entry from
page 2 to page 4 is accomplished by entering a 2 in the Data entry
enable From page box and entering a 4 in the Data entry enable To page
box.

4. For User 3, click the third password box and enter the password for User
3.  By selecting the CONF box, User 3 has access to Configuration
Mode.  Similarly, by selecting the ALOGO box, User 3 will be logged out
after ten minutes.  Because data entry is possible throughout the entire
project, no modifications need to be made to the Data entry enable
boxes.

5. The passwords should now be configured correctly for this situation.
The dialog box resembling this situation is shown in Figure 5-2.

Figure 5-2
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Changing Passwords
This feature allows you to change passwords 2 through 8 defined in the project file
directly from the panel.  To use this feature, there must be at least two passwords
defined, with one of them set to be automatically logged in (see Figure 5-3).  This
means that when the panel goes from Configuration Mode to Operation Mode, the
specified password is logged in.

Figure 5-3  

When the passwords are defined, you must make an ASCII control variable field
for each password that you want to be able to change.  To make a control variable
field, you need to perform two steps:

1. Select the Control Variable icon in the Extra Toolbelt.  The Control
Variable icon is the third from the left in the Extra Toolbelt.

2. Create a control variable field.  You can do this in the same way that you
create a numeric field (you can either double click the left mouse button,
position the cursor where you want the field to begin and select
“Edit→Data Field Type→Numeric/ASCII” or select the Numeric Field
icon in the Toolbelt).  Make sure that you change the display format to
ASCII.  Once you do this, you will be able to select which password (two
through eight) you want to create the field for.

Example
You want to be able to change passwords 2, 3 and 4 (which are 4321, 5690 and
9808, respectively) from the panel.  Once you have clicked on the Control Variable
icon and created the field, you should see the dialog box shown in Figure 5–4.
Again, make sure that you change the display format to ASCII!
Because you are going to change the value of this field (the actual password),
select Read/Write within the Data Access box.  This control variable is addressed
for password 2.  When you click OK, you will see CCCC on your project page,
indicating that you have created a control variable field.
If you follow the same procedure for creating control variable fields for passwords
3 and 4, your page may resemble Figure 5–5.  These control variable fields are
edited in the same manner as numeric fields.
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Figure 5-4  

Figure 5-5
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Enhanced Mode Alarms
Enhanced Mode alarms offers a maximum of 1024 alarms, which are divided into
4 blocks (some models offer 256 total alarms in 4 blocks).  The lower the
numerical value assigned to the alarm, the higher it’s priority.  Each block can be
addressed to any register within the controller’s memory.  Each alarm is
referenced to a bit in the controller.  When the bit =1, the alarm message is
displayed.
It is strongly suggested to use Enhanced Mode alarms.  Compatibility Mode
alarms are included in the software only to provide compatibility with older project
files.  Future releases of the panel’s firmware may not support Compatibility Mode
alarms.
To use Enhanced Mode alarms and the RDA (reserved data area), first disable the
Alarms area of the RDA.  Select Alarms from the Project menu.  This displays the
Alarms dialog box, Figure 6–1 (if RDA is enabled, a dialog box to choose between
Compatibility Mode and Enhanced Mode alarms is displayed).

Figure 6-1  

The Block # field allows block 1, 2, 3, or 4 to be chosen.
The # of Alarms field specifies how many alarms are used in a block.  The
software automatically rounds up the number to a multiple of 16 because the
alarms are addressed as words of information.
The Update cycle field specifies how often the alarms are updated.
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The Block start address field specifies the starting address of the current block.
Click the Reference button to display a detailed dialog box for addressing the
controller.
Click the Advanced button to display a dialog box (Figure 6-2) to choose when the
alarm pop–up window is to appear after an alarm.

Figure 6-2  

Default – Alarms are displayed immediately if no keys are pressed (or have 
been pressed within the last three seconds).

Disable Alarm Pop–up – The alarm pop–up window will not be displayed.
Show Immediately On Any Alarm – The alarm pop–up window will be displayed as

soon as an alarm occurs.
Set Delay After Last Keystroke – Display of the alarm pop–up window is delayed

a specified amount of time after the last keystroke or touchcell 
press (between 1 second and 127 seconds).

Disable Time and Date Display – Disable the time and date display in the alarm 
page.

The alarm messages are viewed using the scroll arrows located to the right of the
alarm message list box.  To create or edit a message, either click the desired value
or use the Alarm # field to select the value and then enter the message. Special
characters may be added to the message by clicking on the Special Chars button.

The On alarm go to page field specifies the page to display when the alarm is
activated.  A key must be programmed in Alarm Mode to use the following
elementary macro commands in sequence: Acknowledge Alarm (if required), Go
to Alarm Page, Page Mode.  Whenever the alarm occurs, the panel will display the
alarm screen.  Implement the arrow keys to select the proper alarm and press the
key that was programmed in the Keyboard Macro Editor to display the correct
page.
The Alarm requires acknowledgment field, if selected requires the operator to
press a key to acknowledge that the alarm is active.  Once the alarm is activated,
the panel will enter Alarm Mode and display the currently active alarms.  The
operator must acknowledge the alarm by pressing the ENTER key for a few
seconds.  Pressing the CLEAR key will return to Operation Mode.  However, it is
still necessary to reset the proper alarm bit.
Selecting Print alarm ON, Print alarm OFF, or Print time of acknowledgment, prints
specific alarm data to a serial printer.
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Select Enable log to event list writes the selected alarm to the historical event list.
Selecting Message Only allows the alarm message to be treated as a message
and not a true alarm.  If this checkbox is marked for a specific message, the Alarm
LED on the panel will remain off for the specific event and the first row of the
message will NOT contain the familiar “A”, as for an alarm message.  It is possible
to require that these messages be acknowledged, just as a standard alarm
message.  These messages can also be logged to the Event List if the Enable log
to event list checkbox is marked.
The familiar WindowsTM features cut, copy, and paste are also available for use in
editing messages.  If you have several alarm messages that are similar, you can
use the Copy alarm text and Paste alarm text features to copy messages and then
make any necessary changes.
Simply select which messages to copy by highlighting them.  If you want to copy
several messages that are in successive order, click on the first one and drag the
mouse down until the last one is highlighted and release the mouse button.  If you
have several messages to copy that are not in successive order, hold down the
Ctrl key,  click on each of the messages that you want to copy, and release the Ctrl
key.  All of these methods will select the text to be copied.
Now, click on the Copy icon to copy the messages into Windows’ Clipboard.
Highlight the alarm message number where you want to paste the first message
and click on Paste alarm text to copy the messages into their new locations.  You
can also use a Windows based text editor, such as Notepad, to create a list of
messages.  To do this, place each message on a separate line.  Use the Copy
function of the editor to copy the text to the Clipboard and then use the Paste
alarm text feature to copy the messages into their new locations.
Example 1
Assume a user wants to use alarms that begin at COMMS1.  Keep in mind that
each alarm message is referenced to a BIT in the controller.  Their alarm
messages and their respective locations in the controller are as follows:

Alarm Location in the Controller Controller Value Alarm Message

COMMS1 1 Pressure too high

COMMS1 2 Temperature too high

COMMS1 4 Pressure too low

1. Select “Project→Alarms”.  The Alarms dialog box will appear, to specify
the starting address for the alarms.  In this example, the alarms begin at
memory location COMMS1.

2. The alarm list box is located beneath the Current alarm block options
box.  This list box is where the alarm messages are entered.  Each
numeric value corresponds to a bit.
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3. The numeric values in the list box and their corresponding alarm
messages would be as follows:
1: Pressure too high
2: Temperature too high
3: Pressure too low

Example 2
Assume you want the panel to display page 3 when alarm 1 is active and that the
alarm requires acknowledgment.

1. Select “Project→Alarms”.
2. Make sure all alarm data is entered correctly, (for the alarm message

and the beginning address of the alarm block).
3. Enter 1 in the Alarm # field.  Enter 3 in the On alarm go to page field.

Click OK.
4. Select Project→Keyboard Macro Editor.  Assume that the F1 key is to

perform the function of acknowledging the alarm.  The dialog box shown
in Figure 6-3 shows how this key should be configured.

5. Keep in mind that the alarm bit must still be reset.  This may be done by
including the macro command “Write to Controller” to the previous
complex macro and clearing the proper alarm bit.

Figure 6-3  

Long Alarm Strings
You can define an alarm message up to 40 characters in length for all panels that
have a 20 character display.  The complete message is displayed in 3 lines.  The
first line is for time and date indication, the second and third lines are for the alarm
message itself.
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Four reserved areas of controller memory are reserved to establish an interface
with the controller.  The starting address of each of these areas are assigned by
selecting Project→RDA Setup. It is not necessary to have a full working
knowledge of the reserved data areas to complete a project.  It is entirely possible
to toggle bits in the controller, display messages and controller data, edit
read/write fields, etc. without having any areas of the RDA enabled.  For this
reason, the RDA is disabled.  This also helps to optimize communication between
the panel and the controller.  There are, however, several functions that are only
available through the RDA.
Figure 7-1 shows the flow of communication for each of the reserved data areas,
while Figure 7-2 shows a memory map of the entire reserved data area.

Figure 7-1

Keyboard Update Area
This reserved area is formatted to contain flags for each key on the panel and
extended keyboard.  These flags are set HIGH when a key is pressed and set
LOW when released.  Each key status flag occupies one bit in the controller
memory.  These bits are used by the controller to detect when a particular key is
pressed and then perform a specific operation.
Note: In the Keyboard Update Area of the RDA, the ENTER key is mapped to  K1,

the CLEAR key is mapped to K16, and the HELP key is mapped to  K15.
Panel Status Update

This reserved area is formatted to contain time and date information from the
panel’s real time clock, a two–byte panel status word, and a current page register.
Real Time Clock
The RTC (real time clock) contains the time and date information.  Depending on
the type of controller that is being used, this information will be stored in either
binary or BCD.



7-2 Reserved Data Area MN1271

Figure 7-2
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Panel Status Word
The panel sets and resets bits S0–S8 and S13–S15 in the Panel Status Word to
indicate its current status.  Your application logic can monitor these bits to
determine how and when it should interact with the panel.  Table 7-1 shows a brief
description of each status bit.

Table 7-1
Bit # Function Description

S0 Link status monitor
flag

Used by the controller to monitor the communication status between the panel and the
controller.  The value of this bit is changed by the panel with a cycle time of approximately
one second.  If a transition is not detected within 1 second, the controller should consider
that the panel is either not connected or not operating properly.  If the cycle time of the
controller program is longer than one second or if there are numerous communication
errors, one transition of the Link Status flag can go undetected.

S1 Data entry active Set whenever the panel is in Data Entry Mode.

S2 Printing in progress Set whenever the panel is sending data to the printer.

S3 Printer status Bit S3 contains the current logic state of the CTS (clear to send) line.  CTS is driven by the
printer and indicates the printer’s readiness to accept data.

S4 Date and time update
in progress

Used to synchronize access to the panel’s real time clock (RTC).  Before writing a new time
and date record, the panel sets bit S4 (it is about to update this data).  The panel then
writes the time and date information to the Reserved Data Area and resets bit S4.  The
controller program should always check the update flag before reading the time and date
record.  If the bit is set, the controller should not use the time and date information.  (This
bit is not set when the panel updates only the seconds field.)

S5 Attempt to access
protected function

Set when the user tries to access a function that is not accessible with the current password.
Since no message is displayed by the panel, the controller can check this status bit and
notify the user that the function they are trying to access is protected.

S6 Battery low Set when the backup batteries become weak.  These batteries maintain Recipe data as well
as time and date information, which is stored in RAM.

S7 Alarm active Set when at least one alarm is active.  Bit S7 is reset when all alarm bits are reset to zero.

S8 Unacknowledged
alarm active

Set whenever there is at least one active alarm that requires acknowledgment.  It is reset
when all alarms have been acknowledged.  If the “Operator ACK Required” attribute is set
will guarantee that bit S8 will remain set until the alarm is acknowledged.  It does not
guarantee that the bit associated with the alarm in the RDA will remain set.  Those alarm
bits are controlled by your application logic, not the panel.

S13 Recipe upload in
progress

Set whenever a Recipe is being uploaded from the controller to the panel.  It is reset when
the upload process is complete.

S14 Recipe download in
progress

Set whenever a Recipe is being downloaded from the panel to the controller.  It is reset when
the download process is complete.

S15 Recipe file status 0= indicates that the Recipes contain valid data.  1= indicates that the Recipe data is corrupt
or still contains the initial values defined in the project file.

Current Page Register (CP)
The panel writes the number of the currently displayed page into the CP register
whenever the panel is in Page mode or Data Entry Mode.  In all other modes, a
zero is written into this register, indicating that page data is not currently being
displayed.  Page numbers are stored in either binary or BCD format, depending on
the controller being used.
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PLC Status Update Area
The Controller Update Area allows the controller to access and control certain
aspects of the panel.  The controller may also request a specific page to be
displayed by writing the appropriate value into the Page Request register.  The
controller control word allows the controller to request the printing of a page,
disable data entry, select an alarm mode, or enable the mailbox function.  All front
panel LED’s are controlled from this area to provide feedback to the operator.
Control of these LED’s is carried out through the Controller Update Area.  Each of
the registers found there are copied to bit address contacts so that the status bits
are referenced as control relays.

Page Request Register (PR)
The page to be displayed is selected either by the operator from the front panel
keypad or by the controller itself.  The controller selects the page to be displayed
by writing the corresponding page number into the PR register in the Controller
Update Area.  When the panel has changed to the corresponding page, write a 0
back into the PR register to return control back to the keys on the panel.  If this is
not done, the display will be “stuck” on that page.  When the panel detects a page
request from the controller, it checks the front panel keyboard.  If no key has been
pressed for the last three seconds, the page selected by the controller is
displayed.
While a controller page request is active (PR not 0), the operator will not be able to
change pages using the arrow keys.  Page numbers are stored in either binary or
BCD format.

LED Control Bits
Bits L1 through L32 control the LED indicators that are found on various panel
models.  The mappings of these bits and the LEDs are shown in Table 7-2.  The
LEDs are controlled by the Keyboard Macro Editor.  For example, the F1 key is
mapped to L1 and the 0 numeric key is mapped to L17.
Table 7-2 shows how these LED’s are mapped.



Reserved Data Area  7-5MN1271

Table 7-2
LED KEY

L1 F1

L2 F2

L3 F3

L4 F4

L5 F5

L6 F6

L7 F7

L8 F8

L9 F9

L10 F10

L11 F11

L12 F12

L13 F13

L14 F14

L15 F15

L16 F16

L17 0

L18 1

L19 2

L20 3

L21 4

L22 5

L23 6

L24 7

L25 8

L26 9

L27 .

L28 +/–
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Controller Control Word
The bits of the Controller Control Word are set and reset by the controller
according to the application logic.  The panel responds to these bits as shown in
Table 7-3.

Table 7-3
Bit # Function Description

C0 Print Screen When set, the panel sends the currently displayed page to the printer.  The bit must be reset
to 0 before another print request is processed. If the current password allows the user to
request prints, the currently displayed page is printed directly from the front panel by
pressing the “Prt Scr” or “9 / PRT” keys (depending on the panel model).

C1 Disable data entry When set, the operator cannot enter the Data Entry Mode on the panel, even if the password
would allow it.  In this way, the controller can temporarily or permanently inhibit
modification of variables.

C2 Select alarm mode When set, the display will NOT switch to Alarm mode automatically.  Instead, the user will
have to select ALARM from the Panel Command menu with the proper keyboard actions.
Once inside the ALARM menu, the user will be able to view and acknowledge any active
alarms (If there are no pending alarms, the user will not be able to enter the ALARM
menu).  Bit C2 only disables the automatic display of the alarm screen. Any alarm
attributes that were set during project development remain active.

When the bit is reset to zero, the display will automatically switch to Alarm mode when at
least one alarm is active.

C15 Enable Mailbox When set, the panel is allowed to cyclically read the data in the Mailbox.  The Mailbox must
be configured prior to setting this bit.

When the bit is reset to zero, the panel will not read the data in the Mailbox, thus reducing
communication time and increasing system performance.

Alarm Update Area
This area of the RDA is used with Compatibility Mode alarms.  This area controls
the display of up to 256 alarm messages.  Each alarm is assigned one bit in the
Alarm Update Area.  To inform the panel that an alarm has occurred, the controller
application logic must set the corresponding bit.  When an alarm has been set, the
display switches to Alarm Mode and displays the corresponding alarm message.
All alarms are archived in a circular buffer called the Event List.  This historical
data can be viewed or printed via the Event Mode.
While it is possible to use this area of the RDA with alarms, it is strongly
recommended to use Enhanced Mode alarms instead.  Doing so will result in
added flexibility in structuring the alarms, as well as having a greater number of
alarms to work with.
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The Interlock Mailbox is a facility that allows the operator interface panel to interact
with the controller’s program.  The Mailbox is simply a group of registers in the
controller memory (from a minimum of 2 registers to a maximum of 20).  The
Mailbox can be placed anywhere in the controller memory.  When the Mailbox is
enabled, the operator panel cyclically reads the contents of the Mailbox from the
controller.  The controller can command the panel to perform certain tasks by
placing data in the memory area used by the Mailbox.  When the panel detects
that the controller has written data in the Mailbox, it interprets the data as a
numeric code for a required command.  If the panel recognizes the command, it
immediately executes it.  If the command requires a response from the panel, the
panel places the response back into the Mailbox itself.

Mailbox Definition
To enable the Mailbox, select “Project→Interlock Mailbox”.  The dialog box of
Figure 8-1 is displayed.

Figure 8-1  

To enable the Mailbox, simply mark the checkbox “Enable” .  The two radio buttons
select how the Mailbox is read:

• Read in cycles
• Read in cycles if PCW (Controller Control Word) flag is set.  If set, the

panel will cyclically read the data in the Mailbox only when bit C15 in the
Controller Control Word of the Reserved Data Area is set (Figure 7-2).
This reduces the overhead of the communication time when there is no
need for the controller to send commands to the panel.

The Read Cycle (500ms–127s) specifies how frequently the operator panel will
read the data in the Mailbox to see if it contains a new command.  The faster the
Mailbox Read cycle, the faster the panel will respond to commands from the
controller.  However, the update of the variables shown on the display will be
slower.
The Interlock reference is the address of the first Mailbox register in the controller
memory.  The address can be entered directly as a string or with a fill in the blank
dialog box displayed by clicking the Reference button.  The starting address must
not overlap memory areas reserved for other panel functions such as alarms, I/O
update, keyboard update, etc.
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Mailbox Structure
The controller can issue commands depending on the values written to the
Mailbox.  Some commands require parameters to be included with the command,
while other commands require the panel to respond with data.  The structure of
the Mailbox in controller memory is shown in Table 8-1.  The Status Word and the
Command/Response Word are always required for the Mailbox. Parameter 0 –
Parameter 17 Words are only used if required by the particular Mailbox command.

Table 8-1
Offset

0 Status Word
1 Command/Response Word
2 Parameter 0
3 Parameter 1
...
19 Parameter 17

You can determine the controller memory addresses of all the data elements in the
Mailbox by using the starting address of the Mailbox area (set by clicking
Reference in Figure 8-1) and the memory map shown in Table 8-1.

Status Word
The Status Word is the main handshaking register of the Mailbox.  Both the
controller and the panel can write to this register.  The status word contains a
binary number, the meaning of which is described in Table 8-2.

Table 8-2
Code Status Written by

0 No request, Mailbox is available Controller
1 Pending request Controller
2 Mailbox busy Panel
3 Error code:  Illegal command Panel
4 Command completed Panel
5 Panel restart Panel

Command/Response Word
The controller specifies which Mailbox command it wants to execute by placing the
code of the desired command in the Command/Response Word.  The available
Mailbox commands and their command codes are given in Table 8-3.  The panel
writes a binary value to the Command/Response Word when it has executed the
command requested by the controller to indicate the result of the operation.

Parameters
The Parameter Words are used only when required by a specific command. Some
commands do not require any parameters. The following section describes how to
use and what Parameter Words are required for each Command Word.
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Mailbox Commands
The Mailbox commands are listed in Table 8–3.  The command codes must be
written by the controller into the Command/Response Word register.

Table 8-3
Command Description

1 Recipe Status
2 Start Recipe Download
3 Start Recipe Upload
4 Set Parameter Set Number
5 Get Parameter Set Number
6 Get Recipe Transfer Priority
7 Set Recipe Transfer Priority
17 Request Data Entry Mode
33 Password Status
49 Start Controller to Controller Transfer With No Confirmation
50 Start Controller to Controller Transfer With Confirmation
81 Set RTC
97 Clear Event List
113 Start Report Printout
114 Stop Report Printout
129 Get Current Language
130 Set Current Language
145 Start Screen Saver
146 Stop Screen Saver
147 Enable Screen Saver in Alarm Mode
148 Disable Screen Saver in Alarm Mode

Recipe Status The controller can use this command to request information on the status of the
Recipes in the panel.
Command code: 1
No parameters are required by this command. The panel will respond with a code
in the Command/Response Word.  The possible codes are listed in Table 8–4.

Table 8-4

Code

Description

0 OK, Recipes contain valid data
1 Error:  Recipes contain initialized data as defined in the project file
2 Error:  There are no Recipes defined
3 Error:  Error in project file
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Start Recipe Download
The controller can use this command to start a Recipe download from the panel
memory to the controller memory.
Command code: 2
Two parameters are required by this command:

Parameter 0
Page Number of required Recipe  (1 – max. page number in project file)
Parameter 1
Parameter set number  (1 – max. number of pre–defined parameter sets)

The panel will respond back to the Command/Response Word with one of the
codes listed in Table 8-5 after performing the operation.  A Recipe transfer may
take several seconds, depending on how many bytes have to be transferred.

Table 8-5
Code Description

0 OK, Transfer completed successfully
1 Error:  Recipes contain initialized data
2 Error:  There are no Recipes defined
3 Error:  Error in project file
4 Error:  Illegal Page number has been requested
5 Error:  Illegal number of parameter set has been requested
6 Error:  The requested parameter set is locked (that is, it is being

            used by the operator panel for a data entry operation)
7 Error:  A communication error occurred during the transfer

Start Recipe Upload
The controller can use this command to start a Recipe upload from the controller
memory to the panel memory.
Command code: 3
Two parameters are required by this command:

Parameter 0
Page Number of  required Recipe   (1 – max. page number in project file)
Parameter 1
Parameter set number  (1 – max. number of pre–defined parameter sets)

After performing the operation, the panel will respond back to the Command/
Response Word with one of the codes listed in Table 8-6.  Note that a Recipe
transfer may take several seconds, depending mainly on the number of bytes that
have to be transferred.

Table 8-6
Code Description

0 OK, Transfer completed successfully
2 Error:  There are no Recipes defined
3 Error:  Error in project file
4 Error:  Illegal Page number has been requested
5 Error:  Illegal number of parameter set has been requested
6 Error:  The requested parameter set is locked (that is, it is being

           used by the operator panel for a data entry operation)
7 Error:  A communication error occurred during the transfer
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Set Parameter Set Number
The controller can use this command to select a given Recipe parameter set.
Command code: 4
Two parameters are required by this command:

Parameter 0
Page Number  (1 – max. number of pages in the project file)
Parameter 1
Parameter Set Number  (1 – max. number of pre–defined parameter sets)

After performing the operation, the panel will respond back to the
Command/Response Word with one of the codes listed in Table 8-7.

Table 8-7

Code
Description

0 OK
2 Error:  Recipes not defined in project file
3 Error:  Error in project file
4 Error:  Illegal page number requested
5 Error:  Illegal record number requested
6 Error:  Requested record locked

Get Parameter Set Number
The controller can use this command to get the current Recipe parameter set
number.
Command code: 5
Only one parameter is required by this command:

Parameter 0
Page Number  (1 – max. number of pages in the project file)

After performing the operation, the panel will respond back to the
Command/Response Word with one of the codes listed in Table 8-8.

Table 8-8
Code Description

0 OK
2 Error:  Recipes not defined in project file
3 Error:  Error in project file
4 Error:  Illegal page number requested
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Get Recipe Transfer Priority
The controller can use this command to get the current Recipe transfer priority
level.
Command code: 6
This command requires no parameters.
After performing the operation, the panel will respond back to the
Command/Response Word with one of the codes listed in Table 8-9.

Table 8-9
Code Description

0 Normal
1 Highest
2 Error:  Recipes not defined in project file

Set Recipe Transfer Priority
The controller can use this command to set the current Recipe transfer priority
level.
Command code: 7
Only one parameter is required by this command:

Parameter 0
Priority Level  (0=Normal, 1=Highest)

After performing the operation, the panel will respond back to the
Command/Response Word with one of the codes listed in Table 8-10.

Table 8-10
Code Description

0 OK
2 Error:  Recipes not defined in project file
3 Error:  Illegal priority setting requested

Request Data Entry Mode
The controller can use this command to switch the operator panel to Data Entry
Mode.
Command code: 17
Two parameters are required by this command:
Parameter 0
Index Number of required Page  (1 – max. page number in project file)
Parameter 1
Index Number of required Data Field  (1 – max. number of data fields on page)
After performing the operation, the panel will respond back to the
Command/Response Word with one of the codes listed in Table 8-11.

Table 8-11
Code Description

0 OK
1 Error:  Illegal page number has been requested
2 Error:  Illegal field number has been requested
3 Error:  Panel is not ready for Data Entry Mode
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Password Status
The  controller can use this command to request information about the current
password status.
Command code: 33
The command requires no parameters.
After performing the operation, the panel will respond back to the
Command/Response Word with one of the codes listed in Table 8-12.

Table 8-12
Code Description

0 No passwords are defined in the project file
1 No valid password has been entered
2 A valid password has been entered
3 The system default password (0007) has been entered

If Code 2 is returned, the Parameter Words will contain the following information:
Parameter 0 Current password level
Parameter 1 First character (ASCII coded) of the current password
Parameter 2 Second character (ASCII coded) of the current password
Parameter 3 Third character (ASCII coded) of the current password
Parameter 4 Fourth character (ASCII coded) of the current password

Start Controller to Controller Transfer With No Confirmation
This feature allows data transfers in two different manners:

1)  Between two controllers.  In this case, the controllers are connected by a
controller network or with the UniNET network.

2)  Between two registers located within the same controller.
Note: Once more than one job has been created, it will be impossible to entirely

delete the first job without also deleting the second job.  For example,
assume there are three jobs, created in the order Job 1, Job 2, Job 3.  If the
user wishes to delete Job 2, they must also first delete Job 3.  However,
modifications can be made to any job at any time.

One complete data transfer is called a job.  When the controller requests a job to
be executed, the panel responds immediately back to the controller and executes
the job as soon as possible.  Therefore, the controller does not know when, or if,
the requested job will be executed.
To set up a transfer, select Project→Data Transfer.  The dialog box of Figure 8-2 is
displayed.  The Job # field is used to select between the different jobs.  Click on
the Source Reference button to specify the register to be read.  The dialog box of
Figure 8-3 is displayed.  Use these fields to specify the type of data, format, and
address of  the register that is to be read.  Click OK to return to the dialog box of
Figure 8-2.
Enter the number of words to be transferred in the appropriate box.  Click the
Destination button to display a dialog box to enter the address to write the data.
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Figure 8-2  

Figure 8-3

If the Job Execution Mode is set to “In Cycles”, the panel will automatically transfer
the data on each cycle.  The cycle period is set between 1 second and 127
seconds.  Remember the faster the cycles, the faster the panel will transfer data,
but it will slow down the rest of the system.  If the Job Execution Mode is set to On
request, the controller must send a  request to the Interlock Mailbox before the
data will be transferred.  After completely setting up the dialog box, click OK.  Now
select Project→Interlock Mailbox.  Set up the Mailbox as previously described.
When the controller sends a request to the Mailbox, the Mailbox will read the
command word and the parameter.  The panel will then send a response word
back to the controller and execute the command.
Command code: 49
This command requires only one parameter:

Parameter 0
Job Number (1–255)

After performing the operation, the panel will respond back to the
Command/Response Word with one of the codes listed in Table 8-13.

Table 8-13
Code Description

0 OK
1 Error:  Controller to Controller not defined at all
2 Error:  Illegal job number
3 Error:  Queue is full
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Start Controller to Controller Transfer With Confirmation
This command is set up in the same manner as the command Start Controller to
Controller Transfer With No Confirmation.
Command code: 50
This command requires only one parameter:

Parameter 0
Job Number (1–255)

After performing the operation, the panel will respond back to the
Command/Response Word with one of the codes listed in Table 8-14.

Table 8-14
Code Description

0 OK
1 Error:  Controller to Controller not defined at all
2 Error:  Illegal job number
3 Error:  Not used
4 Error:  Communication error while reading source data
5 Error:  Communication error while writing destination data

Set RTC (Real Time Clock)
Enables the controller to set the Real Time Clock located within the panel.
Command code: 81
This command requires six parameters:

Parameter 0
Day (1–31)
Parameter 1
Month (1–12)
Parameter 2
Year (00, 01 ....)
Parameter 3
Hour (0–23)
Parameter 4
Minute (0–59)
Parameter 5
Second (0–59)

After performing the operation, the panel will respond back to the
Command/Response Word with one of the codes listed in Table 8-15.

Table 8-15
Code Description

0 OK
1 Error:  RTC error
2 Error:  Requested setting out of range
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Clear Event List From Controller Mailbox
The controller can use this command to request that the panel clear its event list.
Command code: 97
The command requires no parameters.
After performing the operation, the panel will respond back to the
Command/Response Word with a 0, indicating that the event list has been
cleared.

Start Report Printout
This command is used to start a report printout.  The method used in defining
reports is described in Chapter 2.
Command code: 113
This command requires only one parameter:

Parameter 0
Report Number

After performing the operation, the panel will respond back to the
Command/Response Word with one of the codes listed in Table 8-16.

Table 8-16
Code Description

0 OK
1 Error:  Printer process already active (if START command is issued more

than once)
Error: Printer process already inactive (if CANCEL command is issued
more than once)

2 Error:  Illegal report number
3 Error:  Activation queue is full

Stop Report Printout
This command is used to stop a report printout.  The method used in defining
reports is described in Chapter 2.
Command code: 114
This command requires no parameters.
After performing the operation, the panel will respond back to the
Command/Response Word with one of the codes listed in Table 8–17.

Code Description

0 OK
1 Error:  Printer process already inactive
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Get Current Languages
The controller can use this command to get the number of the currently active
language from the panel.
Command code: 129
This command requires no parameters.
After performing the operation the panel will respond back to the
Command/Response Word with one of the codes listed in Table 8-17.

Table 8-17
Code Description

0 OK
1 Error, the project is not multilingual.

If Code 0 is returned, the Parameter Word 0 will contain the number of the active
language.

Set Current Languages
The controller can use this command to change the language in the operator
panel.
Command code: 130

Parameter 0
Language number

After performing the operation the panel will respond back to the
Command/Response Word with one of the codes listed in Table 8-18.

Table 8-18
Code Description

0 OK
1 Error, the project is not multilingual.
2 Error, illegal language number requested

Start Screen Saver
The controller can use this command to immediately activate the screen saver
function.
Command code: 145
No parameters are required by this command.  After performing the operation the
panel will respond back to the Command/Response Word with one of the codes
listed in Table 8-19.

Table 8-19
Code Description

0 OK
1 Error, screen saver not enabled in the project file
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Stop Screen Saver
The controller can use this command to immediately deactivate the screen saver
function.
Command code: 146
No parameters are required by this command.  After performing the operation the
panel will respond back to the Command/Response Word with one of the codes
listed in Table 8-20.

Table 8-20
Code Description

0 OK
1 Error, screen saver is not enabled in the project file

Enable Screen Saver Function in Alarm Mode
The controller can use this command to enable the screen saver in Alarm Mode.
If the panel is in Alarm Mode and the time for the screen saver activation has
elapsed, the screen saver will start.  To stop the screen saver, simply touch a key.
This command code is used following command 148 to enable the screen saver.
Command code:  147
No parameters are required for this command.  After performing the operation the
panel will respond back to the Command/Response Word with one of the codes
listed in Table 8-21.

Table 8-21
Code Description

0 OK

Disable Screen Saver Function in Alarm Mode
The controller can use this command to disable the screen saver function when
the panel is in Alarm Mode.  If the panel has the screen saver activated and an
alarm occurs, the panel will turn off the screen saver and display the alarm page.
The alarm page will be displayed as long as there is a currently active alarm.  Use
command 147 to enable the screen saver.
Command code:  148
No parameters are required for this command.  After performing the operation the
panel will respond back to the Command/Response Word with one of the codes
listed in Table 8-22.

Table 8-22
Code Description

0 OK



Interlock Mailbox  8-13MN1271

Mailbox Programming
To use the mailbox successfully, the panel and the controller must interact exactly.
The interaction between the panel and the controller can be thought of as a short
conversation between two people.
The first person (the controller) tries to start a conversation with the second person
(the panel) on a particular topic (the Mailbox command code).  After the first
person has introduced himself and the topic of the conversation, the second
person decides whether he feels competent enough to join in.  If the second
person decides not to join in the conversation, he politely informs the first person
that he feels he does not know enough about that particular topic to make an
informed comment and waits for a change in the topic of the conversation.  If the
second person does decide to enter into the conversation, he ponders the topic
and then expresses his well–considered opinion.  The vital ingredient in a
successful conversation is that nobody is interrupted while they are talking.
The flow chart in Figure 8-4 describes the program sequences that must be
executed in parallel by both the panel and the controller program to ensure a
successful Mailbox session.
Keep in mind the following:

• At system start–up, the panel writes the special Status Code Panel
Restart to inform the controller that the panel itself has been reset.

• Both the panel and the controller can write to the Status Word and the
Command/Response Word; however, they must not write at the same
time to the same memory location.  Proper operation of the Mailbox is
ensured if the sequence described in the figure is followed.

• The controller program must always wait for the completion of the
current Mailbox session before attempting to start a new one.

• The controller program should always check the status returned by the
panel on completion of a session.
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Figure 8-4  
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Font Editor
Edit Characters  The Font Editor is a tool used to create and modify the downloadable font of

semi–graphical displays.  Each font consists of 256 editable characters.
1. Select “Options→Run Font Editor” at the main menu.
2. The font will appear on the display in the Font Editor as shown below in

Figure 9-1.
3. Double click on a pixel to change the color of that pixel.  For example, if

a pixel is initially black, double clicking on it will change it’s color to white.
Figure 9-1  

Save the Font
1. When a font is modified, it can be saved by selecting Save or Save As

from within the File menu.  (Use Save As and give the font a new file
name and not change the original font.)

2. The font must then be installed by selecting File→Install–View installed
Fonts within the Font Editor.  Select which display panels this font is to
be used with and click on the Install Font button.

3. Now choose Project→Select Font from the main menu and select the
customized font.

Edit Bargraph Characters, Box Characters, and Large Characters
The Font Editor also edits graphic characters.

• Bargraph Characters – The start code for bargraphs is the first
non–blank character within the bargraph character set.  Keep in mind
that the bargraph character set must be kept continuous (i.e., the
characters must be kept in numerical order).  An example of the start
code is shown in Figure 9-2.  Note that the character code will not
remain the same for each font.



9-2  Font Editor & Graphics MN1271

Figure 9-2  

• Box Characters – Select Options→Rectangles and edit the characters
that form each of the two rectangles.  Simply highlight the area on the
rectangle you wish to change and double click on the character that you
wish to replace it with.  Figure 9-3 shows the dialog box that is displayed.

Figure 9-3  

• Large Characters – The large character set must be kept continuous.  A
dialog box is shown in Figure 9-4 that represents the starting character
in a large character set.  Note that this starting character is not the same
for every font.

Figure 9-4  
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Graphics By using a graphics–capable panel, you can import, display, and manipulate
graphics in a project file.  Once the graphic is imported into the project file, it is
easily moved or resized.  The Graphics pull down menu has five selections; Import
Bitmap Graphics, Graphics Library, ISA Symbols, Dynamic Graphics, and
Transparent Graphics.  (These may be accessed by the Extra ToolBelt, with the
exception of ISA Symbols.)

Import Bitmap Graphics
Any file having the extension .BMP or .DIB may be imported.  Simply highlight the
area in which the graphic is to be placed, select Import Bitmap Graphics from the
Graphics menu (or click on the appropriate icon in the Extra ToolBelt), select the
graphic file to be used, and click on OK.  A dialog box is displayed to add a
graphic label, as well as the dithering and imaging options.
Designer can import a 256 color bitmap into a project file for a color panel.  To
configure the software, select Project→Panel Setup and choose VGA 256 Colors.
Example

1. Make sure that the Enhanced graphics support is enabled in the
Project→Panel Setup dialog box.

2. Highlight the area in which the graphic is to be placed by clicking and
dragging the mouse.

3. Select Import Bitmap Graphics from the Graphics menu.  This opens a
dialog box to select a graphic file.  Select the filename and click OK.

4. The dialog box of Figure 9-5 is displayed to label the bitmap and select
import options.

Figure 9-5  

5. The Label is set to the filename of the bitmap file.  Change the label as
desired.  The label is used to recall the bitmap if it is used again in the
project file.

6. You may select image reverse and dithering options.  It is suggested to
import the graphic using the preset values.  If the the graphic is not
satisfactory, import the graphic again using different settings.

7. Figure 9-6 shows how the bitmap file will look after it is imported into the
project file.
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Figure 9-6  

8. A graphic can be moved or resized after it is imported.  To move a
graphic, simply single click the left mouse button over the graphic and
move it to the desired location.  To resize a graphic, single click the left
mouse button once on the graphic and use one of the selection handles
that will appear.

9. To duplicate or copy a graphic within the same page, hold the Ctrl key
down and click on the graphic.  Drag the duplicated graphic to a new
location and release the mouse button.

10. To delete a bitmap graphic, click on the graphic to select it and either
press the Delete key or click on the Cut tool.

Graphics Library Another method to import a graphic is by using the Graphics Library.  Simply
highlight the area you wish to place the graphic and select Graphics→Graphics
Library (or click on the appropriate icon in the Extra ToolBelt).  The dialog box of
Figure 9-7 is displayed.
If the “External” Library source radio button is selected, all of the bitmap graphic
files that are contained within the Graphics subdirectory are listed.  This
subdirectory is located within the main directory of Designer that was created upon
installation of the software.   It is recommended that you place all graphics files
that they frequently use in the Graphics subdirectory.  If the “Current project”
Library source radio button is selected, the dialog box will list all of the bitmap
graphic files that are in use within the current project.
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Figure 9-7  

Select a graphic by single clicking the left mouse button on the filename you wish
to use.  When a graphic is selected, a preview of the image will be shown within
the dialog box.
Example
If you want to import a picture of a blower from the graphics library, do the
following steps.

1. Highlight the area on the screen in which the graphic is to be located.
2. Either select Graphics→Graphics Library or click the icon in the Extra

ToolBelt.
3. Select the file BLWR.BMP.  A picture of a blower is shown in the dialog

box.
4. Click the Import button.  The dialog box of Figure 9-5 is displayed to

label the bitmap and select import options.
5. Click on OK and choose Exit.  This will return you to the page editor

work space.
ISA Symbols The ISA (Instrument Society of America) Symbols floating toolbar allows easy

access to a library of standard industrial symbols.  This feature is accessed by
selecting ISA Symbols from the Graphics menu.  Doing so will bring up the floating
toolbar of symbols that is shown above.  By placing the cursor over a symbol, a
popup tip containing the name of that symbol is displayed.  These symbols are
added to the project file by one of two methods.  First, highlight the area where the
symbol is to be placed, select ISA Symbols from the Graphics menu, and click and
drag the desired symbol to the highlighted area.  The second is to select ISA
Symbols from the Graphics menu and click and drag the symbol to the desired
location.  The symbol may then be resized by selecting the image and using the
handles that appear around it’s outer border.
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Dynamic Graphics  This feature allows the display of a graphic based on a numeric value in the
controller.  Two example are provided to help explain how this feature is used.
Example 1
In this example, assume that there are three possible occurrences.  Display one
image when a blower is on, display a different graphic when a pump is on, or no
graphic when neither is on.  The images are to be displayed at the same location
on the panel.  This is accomplished by referencing the graphics to a single register
in the controller.  Register=0 indicates that neither the blower nor the pump is on.
Register=1 indicates that the blower is on.  Register=2 indicates that the pump is
on.

1. Highlight the location in which the graphic is to be displayed.
2. Select Graphics→Dynamic Graphics or click the appropriate icon in the

Extra ToolBelt.
3. A dialog box is displayed that allows you to select the memory location in

the controller in which the values 0, 1, or 2 will be written.  Since more
than two values are used, the data format selected is a byte.  If only two
values were used, a bit format could be selected (assuming the driver
supports these data formats).

4. Three different values can be written to the controller, either a 0, 1, or 2.
Enter the minimum value 0 and the maximum value 2 and click the Edit
Graphics button.

5. Another dialog box is displayed that allows you to associate the graphic
with a value.  To assign a value to a graphic, either click on the value
that is to be used or select the value by  using the up and down arrow
keys located next to the “Current value” box.  No graphicis needed for
the value of 0, leave this value blank and select the value of 1.  This is
the first value that will have a graphic associated with it.

6. When the value is selected, a graphic needs to be associated with it.
Click on the From Library... button.  (To import a graphic, click the Import
New... button and select the proper location of the graphic, as well as it’s
filename.)

7. A dialog box will appear to select a graphic.  This is the same dialog box
that appears whenever Graphics Library is selected (Figure 9-7).  The
value of 1 is selected (blower is on).  Selecting the filename BLWR.BMP
will display a preview of the graphic.  Click the Import button.  A dialog
box to select the label, imaging and dithering options is displayed.  Once
these have been set, click OK to return to the dialog box of step 5.

8. Perform the same procedure for selecting the value of 2 and the graphic
of a pump (the filename for the pump is PUMP.BMP).  Once this is
completed, the dialog box that contains the graphics and their values will
look similar to the screen capture shown in Figure 9-8.  Clicking OK will
return to the dialog box that the address and the minimum and maximum



 Font Editor & Graphics  9-7MN1271

values were set.  Clicking OK from to complete the procedure and return
to the page editor work space.

Figure 9-8  

Example 2
For this example, assume a graphic is to appear in one of three different locations
on the screen, depending upon what is happening.  Assume there are four
possible occurrences.  The blower is on, the pump is on, both are on, or neither is
on.  If neither is on, the display screen is blank.  If the blower is on, the graphic of
the blower will appear in the second screen location.  If the pump is on, the
graphic of the pump will appear in the third screen location.  This can be
accomplished by using a different memory location for each graphic that is to be
displayed.  Since nothing is displayed when the pump and blower is off, we only
need to create two graphics fields in the project file – one field for the graphic of
the blower and the other field for the graphic of the pump.

1. Highlight the area in which the graphic of the blower is to appear.
2. Select Graphics→Dynamic Graphics or click the appropriate icon in the

Extra ToolBelt.
3. A dialog box is displayed to select the memory location in the controller

that is to be used.  Since we are using a memory location for each
graphic, the data format of these fields can be set as a bit.  The graphic
is either displayed or it is not displayed.

4. Since there are only two choices, set the minimum value to 0 and the
maximum value to 1.  If the selected memory location has a value of 1,
the graphic will be displayed.  If the memory location has a value of 0,
the graphic will not be displayed.  Once the minimum and maximum
values are entered, click the Edit Graphics button.
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5. Another dialog box is displayed to associate the graphic with a value.  To
assign a value to a graphic, either click on the value that is to be used or
select the value by using the up and down arrow keys located next to the
“Current value” box.  Since the graphic is only displayed when the value
is 1, select the value of 1.

6. When the value is selected, a graphic needs to be associated with it.
Click on the From Library... button.  (To import a graphic, click the Import
New... button and select the proper location of the graphic, as well as it’s
filename.)

7. A dialog box allows you to select a graphic.  This is the same dialog box
that appears whenever Graphics Library is selected (Figure 9-7).  The
value of 1 is selected (blower is on).  Selecting the filename BLWR.BMP
will display a preview of the graphic.  Click the Import button.  A dialog
box to select the label, imaging and dithering options is displayed.  Once
these have been set, click OK to return to the dialog box of step 5.

This completes the blower graphic, now the pump graphic is inserted.
1. Highlight the area in which the graphic of the blower is to appear.
2. Repeat steps 2 through 6 for the blower graphic.  In step 7, select the

filename PUMP.BMP for the pump.
Figure 9-9 shows the what the dialog boxes should look like when the graphic for
the pump and the blower have been correctly imported.

Figure 9-9  

Pump Blower
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Transparent Graphics
Transparent graphics allow the overlay of dynamic fields or static text in front of a
bitmap graphic.  An example using this feature is provided.
Example
Assume you want to simulate the fill level of a tank.  In this case, a transparent
graphic of a tank could be used along with a bargraph to simulate the fill level.
The procedure for implementing this feature is as follows:

1. Highlight the area in which the graphic is to be placed.
2. Import the graphic that is to be used (a tank in this case).
3. Select Graphics→Transparent Graphics or click the appropriate icon in

the Extra ToolBelt. Note that the graphic is visible or invisible by simply
selecting Graphics→Transparent Graphics (or by using the icon in the
Extra ToolBelt). This allows the graphic to be repositioned or resized.
Also, it is necessary to have Transparent Graphics on to place static text
or dynamic fields at the same screen location as the graphic.

4. Highlight the area in which the field (a bargraph field in this case) is to be
placed.

5. Select Edit→Data Field Type→Bargraph or click the proper icon in the
Extra ToolBelt.

6. A dialog box to configure the bargraph is displayed.  Configure the
bargraph and click OK.  The procedure is now complete.

Recommendations and Tips
1. If Import Bitmap Graphics or the Graphics Library are used, a button

labeled Info... is displayed in the initial dialog box.  Click this button to
display an additional dialog box that contains information specific to the
graphic file that is selected.  This information includes the name of the
file, the file format, the width and height of the graphic in pixels, the
number of colors used, and if there is any type of file compression.  This
displays the resolution of the graphic before it is actually imported into
the project file.  If visual effects are important, use a professional image
processor to edit color graphic images before importing them into a
project page.

2. In most cases, a complex image that contains many colors or many
levels of gray looks the best when imported using Bayer dither.  An
image composed of only a few colors (or monochrome – only one color)
generally looks the best when imported using the no dither option.

3. Graphics can be no larger than the size of the entire screen.  In other
words, you can not place a graphic that is 640 X 400 on a 500 X 300
screen.

4. Graphics that do not take up the entire screen can be moved, resized,
and copied.  Single clicking the left mouse button anywhere on the
graphic will select it, displays the selection handles.  These handles are
used to move or resize the graphic.
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5. For best visual effects, resize graphics in integer multiples.  For
example, if the graphic is 32 X 30, recommended sizes would be 64 X
60, 128 X 120, etc.  It is also recommended to use graphics whose
resolution best matches that of the panel.  For example, importing a
graphic that has 1024 X 1024 resolution onto a panel that has 640 X 400
resolution will result in distortion.

6. Color graphics can be imported onto a monochrome panel.  Designer
will attempt to cast the graphic in monochrome the best that it can.  This
will produce halftone effects, which are dots that simulate different levels
of gray using different densities of monochrome pixels.

7. When using more than one graphic, they cannot overlap one another.
8. Neither static text nor dynamic controller fields (such as the bargraph in

the transparent graphics example) can be placed in the leftmost column
of the transparent graphic.

9. When importing a graphic, it’s size in pixels is displayed at the right side
of the status bar located at the bottom of the Designer screen.  The
selection size status bar indicator, which shows the pixel width and
height of the selected graphic, will be displayed.  This is a good way to
monitor the change in the size of the graphic.

10. If a single graphic is to be used more than once in a project with different
imaging and/or dithering options, there must be a separate label (name)
assigned to each unique imaging/dithering combination.

Color A color panel can display any combination of 16 colors.  To access the color
option, select Edit→Color palette from the main menu, or click on the appropriate
icon in the Extra ToolBelt.  The dialog box of Figure 9-10 is displayed.
This dialog box allows you to change the background and foreground colors
(either static text or data fields).  Select whether to change these colors on a
global level or on a current selection.
To change the colors for all new pages, select the colors and click the Pick text
color button.  To change the colors only for the currently selected area, select the
colors and click the Change button.
The area below the palette bars and above the buttons indicate the global setting
for the project file.  For example, in the dialog box of Figure 9-10, the colors are
set for a white background and a black foreground.  Every page that is created will
have these colors unless you select a different color and click the Pick text color
button.
Note: The Pick text color button will change to Pick field color whenever a data

field is selected.  Likewise, the area below the palette bars that shows the
global setting will also change from Text color to Field color whenever a
data field is selected.
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Figure 9-10  

Global Change Background/Foreground Color
1. Select Edit→Color palette or click the appropriate Extra ToolBelt icon.
2. Select the color(s) to be used and click on the Pick text color button.

Note: If the background/foreground colors are the same, a dialog box asking if this
is what they wish to do.  (If the background color and the foreground color
are the same, everything will appear transparent and no data fields or static
text will be visible.)

Change Selected Background/Foreground Color
1. Highlight the selection to be changed.
2. Select Edit→Color palette or click the appropriate Extra ToolBelt icon.
3. Select the color(s) to be used and click on the Change button.

Making the Colors of a Data Field or Static Text the Global Default Colors
1. Position the cursor somewhere on the data field or on the static text.
2. Select Edit→Color palette or click the appropriate Extra ToolBelt icon.
3. Click on the Pick text color button.

Note: Each field can have only one color.  For example, a field displays a two digit
number.  If the first digit is blue, the second digit must also be blue.
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Finding Out the Colors of a Particular Area or Field
1. Select Edit→Color palette or click the appropriate Extra ToolBelt icon.
2. Position the cursor on the desired location by single clicking the left

mouse button.
3. Click on the title of the dialog box.  The currently selected colors for the

area will be reflected in the color palette bars.
Note: Each field can have only one color.  For example, a field displays a two digit

number.  If the first digit is blue, the second digit must also be blue.
256 Color Support

Designer can import a 256 color bitmap into a project file for a color panel.  To
configure the software, select Project→Panel Setup and choose VGA 256 Colors.
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Data retentive memory can be used to permanently store data for use by an
attached controller.  This data is read from or written to the controller.  This
concept is termed Recipes and offers a powerful way to extend the capabilities of
the controller.
Recipes are configured by simply adding the controller data items to the project
page as Recipe data items.  To add a Recipe data item, select Edit→Data Field
Source→Recipe Data from the main menu and press the “Enter” key on your
keyboard. (or select the Recipe icon from the Extra ToolBelt and press Enter).
Recipe data items contain all the information associated with normal controller
data items, but instead of reading or writing directly to the controller, the data is
read/written to the panel memory during normal operation.  The controller is then
only read from/written to during an explicit instruction to read/write to the controller.

Example It is not necessary to create a complex project to try Recipes.  This example
shows how to define a very simple Recipe in a few steps.

1. Make sure that the panel is in Configuration Mode.
2. Connect the panel to the personal computer and the controller using the

correct cables.
3. Start the Designer software. Place the cursor on the page and type the

text shown in blue.
4. Define two numeric fields with different addresses as shown in Figure

10-1.
Figure 10-1  

5. Select Edit→Data Field Source→Recipe Data from the main menu and
press the “Enter”.

6. Define two Recipe data items with the same addresses as given to the
numeric fields that were created in step 4.  The two Recipe data fields
will be shown on the Designer page with the placeholder ’R’ instead of
the ’9’ used for numeric fields (see Figure 10-2).
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Figure 10-2  

7. Select Page→Recipe Configuration.  This will display the dialog box
shown in Figure 10-3.

8. Enter 4 for the Number of Parameter Sets and initialize the Recipe
values as shown in Figure 10-3.  Note that the Recipe Item addresses
will be the addresses of the fields that were defined earlier.  Click OK to
confirm the operation.

Figure 10-3 

9. Enter the Keyboard Macro Editor and configure the F1 key using the
command Recipe Control to download the parameter set.

10. Download the project to the panel either by pressing the F2 key on the
computer keyboard, by selecting the Download icon in the Extra
ToolBelt, or by choosing Download from the Transfers menu.
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11. When the download is finished, the panel will go into Operation Mode.
The variables in the left column represent the content of the controller
memory.  The column on the right represents the content of the first
Recipe parameter set once the F1 key is pressed.

12. Pressing the F1 key will cause the panel to begin downloading the
current Recipe parameter set (which is parameter set 1).  After a few
seconds, the operation will be completed and the content of the
controller memory will show the same values as those that are stored in
parameter set 1.

Adding Recipe Data Items
You can add Recipe data items to a page by selecting Edit→Data Field
Source→Recipe Data from the main menu.
Note: When Recipe Data is selected, all data items that are added to the page are

Recipe data items.

Initializing Recipe Data Items
A Recipe is associated with a particular page and is composed of all the Recipe
data items on that page.  However, a Recipe can have different parameter sets.  A
Recipe parameter set is created by assigning particular values to the Recipe data
items on a page.  All parameter sets of the Recipe contain different values and
control different processes.  This allows many different sets of parameters for the
controller.  One set may be used to configure the controller to for production of 2
mm screws, another set may configure the controller for production of 5 mm
screws, and yet another to control the production of 7 mm screws.  Each set of
parameters are stored in a different parameter set within the same Recipe.
Specify the number of parameter sets contained within a Recipe, as well as assign
the initial values to each parameter set from the Recipe Configuration dialog box.
This dialog box is accessed by selecting Page→Recipe Configuration. The initial
values entered for a particular Recipe data item are in the format specified in the
define field dialog box for that data item.
For example, if a numerical format of hexadecimal was entered in the define field
dialog box for a Recipe data item, then all the values entered in the Recipe
Configuration dialog box for this Recipe data item will also be in hexadecimal.  If a
value of 10 is entered in the Recipe Configuration dialog box, the 10 will be
interpreted as 10 hexadecimal (16 decimal).
Note: Recipe data items must be defined on the current page before entering the

Recipe Configuration dialog box.
The Recipe Configuration dialog box is in the form of a spreadsheet.  Each row is
associated with a particular Recipe data item.  The controller address of the
Recipe data item is displayed at the far left hand side of the row.
Each column is associated with a particular parameter set of the Recipe.  The
initial values for a particular parameter set are fully specified by entering a value
for each row in the column.  Each parameter set is identified by a numeric number.
The first column corresponds to parameter set 1, the second column to parameter
set 2, and so on.
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Selecting Parameter Sets & Controlling Transfers
Control Variables offer a means of controlling and monitoring the Recipes.  Control
Variables are special data items that are stored in panel memory.  You can control
certain panel operations by modifying the values held in these internal variables.
Select Edit→Data Field Source→Panel Control Variable.  All newly added data
items will be Control Variables.
There are 8 types of Control Variables:  Recipe File Status, Recipe Parameter Set
Selection, Recipe Action, Data Entry Status, and Data Entry Field Number, Recipe
Page for Selection, Language and Passthrough Status.  The first five will be
discussed here.  The other control variables are found within their respective
sections (i.e., Language is explained in the Multilanguage section, Recipe Page for
Selection is explained with Recipe Menus, Passthrough Status is explained in
Panel Setup).

Recipe File Status Within panel memory is a single memory location that is used to store the
status of the entire Recipe data in the panel.  The Recipe File Status can only
have two values, 0 or 1.  A value of 0 indicates that all of the Recipe data for every
page in the project is valid.  A value of 1 indicates that an error in some part of the
Recipe data was found.  This means that the integrity of the Recipe data is
compromised.
If the Recipe File Status has a value of 1 the user must physically change the
value of one of the Recipe data items to reset the Recipe File Status to 0.  Until
this occurs, the user will not be able to perform Recipe transfers.

Recipe Parameter Set Selection
For each page that contains a Recipe, a separate memory location is reserved for
the Recipe Parameter Set Selection for each Recipe page.  This memory location
stores the numeric identifier of the currently selected Recipe parameter set for the
Recipe page.
Recipe Parameter Set Selection data items can be added to the project.  These
data items are used to visually display the selected Recipe parameter sets of the
various Recipes in the project file.
After adding these data items to the project, specify which Recipe is to be
monitored by the data item (the page number that contains the required Recipe).
Example
A project may contain three Recipes, one on page 2, one on page 3 and the other
on page 7.  To monitor the currently selected Recipe parameter sets of these three
different Recipes, it is necessary to add three Recipe Parameter Set Selection
data items to the project.  One of these data items is used to monitor the Recipe
on page 2, one to monitor the Recipe on page 3 and the other to monitor the
Recipe on page 7.  These three Recipe Parameter Set Selection data items could
all be placed on any page of the project.  Regardless of where they are placed in
the project, the address of the first data item is for Recipe Parameter Set Selection
2, the address of the second is for Recipe Parameter Set Selection 3 and the
address of the third is for Recipe Parameter Set Selection 7.
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You can also change the parameter set of a Recipe on a particular page by
modifying the value held in the Recipe Parameter Set Selection variable.  This is
done in the same way as changing the value of a normal controller data item.  For
example, to make Recipe parameter set number 3 the current parameter set,
enter a value of 3 in the appropriate Recipe Parameter Set Selection variable.  To
do this, select the Recipe Parameter Set Selection variable as a Read/Write
variable.

Recipe Action For each page that contains a Recipe, the panel reserves a separate memory
location for the Recipe Action for that Recipe page.  The Recipe Action memory
location stores the current status of operation of the Recipe for the page.  You can
add Recipe Action data items to the project.  These data items can then be used
to visually display the current state of the various Recipes in the project.
When you add these data items to the project, they must specify which Recipe is
to be monitored by the data item.  This is done by specifying the page number that
contains the required Recipe.   A Recipe Action data item can take on only 3
values: 0, 1 or 2.
0 indicates that the Recipe is in its normal state of operation.  In this mode, the
values of the Recipe data items are displayed on the panel and they can be
modified.
1 indicates that the Recipe data for the currently selected parameter set is being
transferred to the controller.  When the transfer is complete the value is
automatically reset to 0.
2 indicates that the Recipe data for the currently selected parameter set is being
transferred to the panel.  When the transfer is complete the value is automatically
reset to 0.
A Recipe transfer is started by entering a value of 1 or 2 in the Recipe Action data
item.  Entering a value of 1 will force the panel to send the Recipe data for the
currently selected parameter set to the controller.  Entering a value of 2 will force
the controller to transfer the Recipe data for the currently selected parameter set
to the panel.

Data Entry Status  This control variable will be set to a 1 while the panel is in Data Entry Mode.  In
all other modes it will be set to 0.

Data Entry Field Number  This control variable simply contains the field number of the selected
data entry field whenever the panel is in Data Entry Mode.

Recipes and the Keyboard Macro Editor
Recipe transfers can also be performed by using the Keyboard Macro Editor.
Program the keys using Page n mode (where n is the page on which the Recipe is
located).  Select the Recipe Control macro command from the Commands toolbar
of the Keyboard Macro Editor to download, upload, or select a parameter set on
any given page.  Use the Control Variable Step macro command, to assign a key
or touchcell to toggle through the different parameter sets.
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Recipe Menu Support – Not currently supported
A Recipe Menu is a menu–like feature that simplifies recipe parameter set
selection using a user–friendly interface.  Names are used to describe the
parameter set instead of numbers.  Each name represents one Recipe Parameter
set.  Therefore, each Recipe Parameter set must be given a name.  A Recipe Data
Item field is added on the page where the recipe is located.  This field allows you
to set its display format to ASCII,  initialize the Recipe Item values and assign a
name for each parameter set.  This ASCII field is called a Recipe Name field.
Note: This field is not a field type name; it only describes the field’s purpose.
A Recipe Name field must be defined to enable Recipe Menu support. There are
three specific fields that support the Recipe Menus:

� Recipe Menu field, the actual field that displays the menu with recipe
names.  The currently selected recipe parameter set is indicated using
user defined attribute combinations (blink, highlight, reverse).

� Recipe Page For Selection field shows the number of the page
containing the actual recipe data referred to by the Recipe Menu.

� Recipe Key field is not directly connected with Recipe Menus.  It is a less
user–friendly way of selecting a recipe parameter set by name.  To
choose a recipe parameter set, the user must edit the field (instead of
being able to select it from a menu). It can also be used to show the
currently selected Recipe Parameter Set name for a specific page.  The
Recipe Key field must refer to a specific page with a defined Recipe
Name.

These fields do not depend on each other and can be placed in any combination
on any page in the project.
A set of keyboard macro commands support Recipe Menu:

� Go To Recipe Menu macro jumps to a specified page and sets the value
of the Recipe Page For Selection.

� Scroll Recipe Menu macro is used to move the selection in the Recipe
Menu field.  This is the way that a new Recipe Parameter set name is
chosen from the list.

� Confirm Recipe Menu Selection macro changes the current recipe
parameter set to the one selected in the Recipe Menu field.

Define A Recipe Name  The Recipe Name should be defined for all of the pages containing
recipes that are going to be handled using Recipe Menu.  It is also necessary for
the pages that are referred to by Recipe Key field(s).  The Recipe Name is defined
by adding a Recipe Data Item field of ASCII display format on the page with
recipes and filling the Recipe Item values with a name for each Parameter set.
Note: This ASCII field is not an internal variable in the panel memory.  It needs to

be addressed to a physical location in the PLC memory. The amount of
memory required depends on the length of the ASCII string: one byte per
character.
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Here is the procedure that describes how to add a Recipe Name definition.  It
assumes that the current page is the page with defined recipes and that it is the
page for which you want to add a Recipe Name.  Figure 10-4 shows the Recipe
Configure dialog box.

1. Add one Recipe Data Item field.
2. Set the Display format to ASCII.
3. Set Data Access to Read/Write if you want to make recipe names

editable.
4. From the Page menu choose “Recipe Configuration …” to open Recipe

Configure dialog box.
5. Fill the new Recipe Item with names for each Recipe Parameter Set.
6. Select this new Recipe Item by clicking on the button with the record

number. Note that the entire row highlights.
7. Click on the Set As Recipe Name button to set this Recipe Item to be the

Recipe Name. Note that the asterisk “*” appears to the right of the
Recipe Item name.

8. Click on the OK button to accept the changes.
Figure 10-4  
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Create a Recipe Menu Field
The Recipe Menu field is the field that displays the menu with the Parameter Set
names.  It displays recipe names for the page which number is contained in the
Recipe Page For Selection internal variable.  The value of this variable is
displayed and changed using the Recipe Page For Selection field.  Its value can
be automatically set by the Go To Recipe Menu macro command.
The currently selected recipe name is indicated with a user defined attribute
combination (blink, highlight, reverse).  To enable Recipe Menu support, at least
one page with Recipe Name must be defined.
Note: The only field on the page needed for displaying a Recipe Menu is the

Recipe Menu field. Other fields can show additional information but are not
necessary.

If Recipe Page For Selection contains the page number of a page without a
Recipe Name field defined, the Recipe Menu field will display asterisks (“*”).
The following procedure describes how to add a Recipe Menu field.

1. Select an area on the panel screen by dragging the mouse.  This area
will contain the Recipe Menu field.

2. From the Edit menu choose Recipe Menu or press Ctrl–R.  Click once
anywhere on the panel screen to clear the selection; a solid box
represents the Recipe Menu field.

3. Double click on the Recipe Menu field to open the Recipe Menu dialog
box (Figure 10-5).

4. Adjust the width and height if not satisfied.
5. Choose the attribute combination for indicating the selected recipe

name.
6. Select Yes or No for Shown Record Numbers before Record Name,

depending on whether you want to show record number (which is just
the parameter set number) together with the recipe name.

7. Click on the OK button to accept changes.

Recipe Page for Selection Field
The Recipe Page For Selection is a Control Variable.  The purpose of the Recipe
Page For Selection field is to show the number of the page containing the actual
recipe data referred to by the Recipe Menu.
It can be placed on the same page with a Recipe Menu field to show the “recipe
page number”.  It can also be edited to change the page for which Recipe Menu
field displays information.  If Recipe Page For Selection contains the page number
of a page without a Recipe Name field defined, the Recipe Menu field will display
asterisks (“*”).  After powering up the panel, the Recipe Page For Selection is set
to zero.
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Figure 10-5  

Recipe Key Field
The Recipe Key field is an ASCII field of type Control Variable.  The Recipe Key
field displays the currently selected Recipe Parameter Set name for the referred
page.  Like a Recipe Menu field, it can be used to change the selected recipe
parameter set by name but in a less user–friendly way.  Using this method, edit the
field and type the recipe name.
The page to which a Recipe Key field refers to must have a defined Recipe Name
field.  If the referred page has no Recipe Name field defined, the Recipe Key field
will display asterisks (“*”).

Recipe Menu Keyboard Macros
Three special keyboard macros support Recipe Menus (Figure 10-6).

� Go To Recipe Menu macro sets the Recipe Page For Selection and
jumps to the specified page.  This is the preferred way of going to a
Recipe Menu page (page with Recipe Menu field).  The other way is to
set the page number in the Recipe Page For Selection field and then go
to the Recipe Menu page using any other page changing macros (Go To
Page, Next Page, etc.).

� Scroll Recipe Menu macro is used to move the selection in the Recipe
Menu field.  With this macro command you can choose a new Recipe
Parameter Set from the list.  Positive values for the scroll step move the
selection down, while negative values move the selection up.
If there are many recipe parameter sets, more than one key can be
assigned to Scroll Recipe Menu macros: two keys with step of 1 (–1) for
“fine” scrolling and two other keys with step greater than 1 for “fast”
scrolling.
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� Confirm Recipe Menu Selection macro accepts the selected parameter
set name and sets the current recipe parameter set to the new value.  It
can be assigned to a key that includes the Return To Initial Page macro
to “close” the Recipe Menu page and return to the page jumped from
with the Go To Recipe Menu macro.

Figure 10-6  

Recipes and the Interlock Mailbox
The Interlock Mailbox offers a powerful way to control the operation of Recipes
from the controller.  There are seven mailbox commands available to function with
Recipes:

� Start Recipe download
� Start Recipe upload
� Recipe status
� Get parameter set number
� Set parameter set number
� Get Recipe transfer priority
� Set Recipe transfer priority

The mailbox commands allow the choice of the Recipe page and also of the
parameter set.  All mailbox commands related to Recipes return a completion
code describing the results of the operation.  The mailbox interface to Recipes is
particularly useful if it is necessary to transfer a sequence of Recipes to/from the
panel.
Please refer to the chapter on the Interlock Mailbox for command specific
information.
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Multipage Recipe Support
Previous pages have described a straightforward recipe organization.  Many
recipes can be defined in a Project, each recipe was limited to a single project
page.   This chapter describes the Multipage Recipe organization.  Now, the data
which is logically part of a single recipe can be scattered over several project
pages and can still be selected, downloaded or uploaded with a single command.
A recipe that spans several pages is called “Multipage recipe”.

Multipage Organization
Only one multipage recipe and as many single–page recipes as as desired can be
included in a project.  The multipage recipe can contain any number of pages,
even all pages in the Project.

Designer Configuration
To enable the Multiple Page Recipe feature you should define the desired number
of single page recipes in your project and for each of these pages you should
check the “Multipage recipe” checkbox in the Recipe Configuration dialog box as
shown in Figure 10-7.

Figure 10-7  

By marking the checkboxes, all multipage recipe pages are linked together and
any recipe–related action performed in run–time on any linked page will be
performed for all the pages.  This refers to parameter set selection, upload and
download.  In other words, the set selection, the download and upload process
can be done by referring to each page contained in the multipage recipe.
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Define an equal number of parameter sets in all pages belonging to the multipage
recipe, otherwise the upload and download of the recipe may be aborted in the
middle.  Also, be sure that the variables on the pages of the multipage recipe are
different. Otherwise, you could have problems in data integrity during download
and upload operations.  For any recipe page not contained in the multipage recipe,
simply leave the checkbox unchecked.  In all pages belonging to the multipage
recipe, the checkbox must be checked.

Menu Recipe Feature in Multipage Recipe
Recipe Menu features are enabled on the multipage recipe and you can manage it
with the menu in the same way as single page recipes.  Be sure that the recipe
name is defined in only one page of the multipage recipe.  If you want to display
names in the recipe menu for the multipage recipe the Recipe Page for Selection
field must refers to the page that contains the ASCII field declared as “Recipe
Name”.
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Introduction Creating touchcells is made easy by using the floating toolbar, Figure 11-1.
Figure 11-1

Create a panel key touchcell (F1, ENTER etc.).

Create a pushbutton touchcell.

Create a 2, 3 or 4 position selector switch.

Create a touchcell and configure it as a panel
key, an ASCII character or as a macro command.

Select, move and resize objects.

Create an ASCII character touchcell

Create an illuminated pushbutton touchcell

Create an indicator lamp.

Note:  Place an LED indicator on the face of the touchcell by clicking the
Reference tab and marking the box Attach to controller reference.  The LED
will display the state of the address entered in the Button reference box.

Gauge

Time/Date Box

Trend Viewer

Text Box

Note: When you touch a read/write numeric field, a keypad appears to allow data
to be entered.

Data Entry Page  The data entry page in all touchscreen panels includes the display of the
minimum and maximum value associated with the field under data entry.  If a
custom data entry page is created, the min and max values will not be displayed.

Display Window  The display window is a preview window that appears when you begin to define
a touchcell.  This window allows you to see how the touchcell will look before it is
actually created and placed into a project file.
Clicking the left mouse button on the touchcell in the preview window will simulate
pressing the touchcell.  Clicking the right mouse button in the preview window will
simulate the indicator light or the light on the illuminated touchcell changing state.

Touchscreen Menu  The TouchScreen menu appears when a touchscreen panel is selected.  The
menu items include:

Show Touchscreen Grid – Displays a grid to help create touchcells.
Touchcells can be as small as a single character or as large as the entire
screen.

Show Touchscreen Cells – View or not to view the touchcells in the project
file.  If selected, you will see the touchcells as they appear on the panel.
If not selected, you will not be able to see the touchcells in the project
file.  When the project file is downloaded, all touchcells will be visible on
the operator interface panel.

Show Toolbox – View or hide the Toolbox.  The Toolbox is a floating toolbar
that is used to create various types of touchcells and indicators. To
create touchcells, this item must be selected.
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Delete All Touchcells – Deletes all of the touchcells and associated graphics
and commands on the current page of the project file.

Select Touch Font – Select the font to be used for a particular touchcell.
Once a font is selected, it will continue to be used for all touchcells that
are subsequently created.  This font is not a global font and may be
changed at any time without affecting any of the previously created
touchcells.

Creating a Panel Key Touchcell
To create a touchcell as a panel key, select the area where the touchcell is to be
located and click on the Panel Key icon in the Toolbox.  The dialog box of Figure
11-2 is displayed.

Figure 11-2  

General Tab
Within the General index tab, specify how the touchcell is to look by selecting one
of the radio buttons within the Looks area of the dialog box.
Click the Select panel key … button, and select the panel key that the touchcell is
to represent (Figure 11-3). The selected key is highlighted and is displayed in a
different shade than the other keys.  To access keys other than F1 through F8,
click on the right arrow located on the slide bar.

Figure 11-3  
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Text and Colors Tab
Click the Text and Colors index tab to display the dialog box of Figure 11-4.

Figure 11-4  

Legend – the text that is placed either on or on top of the touchcell.  The position
is selected by choosing either the Top or Center radio button within the Legend
position section of the dialog box.
On – the color of the touchcell when it is pressed.
Off – the color of the touchcell when it is in the not–pressed state.
Background – the color of the touchcell background (the rectangle around the
circular or elliptical touchcell not covered by the cell).  Rectangular touchcells have
no background if the touchcell text is centered, but if it is positioned on top, a strip
of background appears above the cell.
Fg – the color of the touchcell text.
Bg – the background color of the touchcell text.  This color is only displayed when
the Transparent checkbox is not marked.  Otherwise, the background of the
touchcell text is the “On” or the “Off” color for centered text and in the Background
color if the text is on top.
Select Font … button – selects the font for the touchcell.  Figure 11-5.  This is
NOT a global setting and different fonts can be used for touchcells in the same
project file.
Custom Tab
Within the General index tab, if Custom is selected, you can import bitmap
graphics for the different states of the touchcell.  Selecting Custom displays a
property sheet shown in Figure 11-6.  The graphic can be imported from disk or
from the Graphics Library.
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Figure 11-5  

Figure 11-6  

To import a graphic from disk, perform the following steps:
1. Click the External radio button in the Image source portion of the dialog

box.
2. Click the Load image … button.
3. Select the path and the filename of the bitmap graphic that you wish to

import.
4. A dialog box is displayed to specify the label that is associated with the

graphic and whether or not to reverse the image.
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To import a graphic from the Graphics Library, perform the following steps:
1. Click on the Library button within the Image source portion of the dialog

box.
2. Click on the Load image … button.
3. A dialog box is displayed to choose a graphic from the Graphics Library

or a graphic that is already used elsewhere in the project file.  To use a
graphic from the Graphics Library, select the External radio button within
the Library source portion of the dialog box.  To use a graphic that is
used in the current project file, select the Current Project radio button.

4. Click the name of the graphic that is to be used (a preview of the graphic
is shown) and click on the Import button.

5. Another dialog box will be displayed to specify the label associated with
the graphic and whether or not to reverse the image.

Creating an ASCII Character Touchcell
To create a touchcell as an ASCII character, select the area where the touchcell is
to be located and click on the ASCII Character icon in the Toolbox.  A dialog box is
displayed as shown in Figure 11-7.

Figure 11-7  

Specify the touchcell appearance by selecting one of the radio buttons in the
Looks area of the General index tab.  The ASCII character that is to be transmitted
when the touchcell is pressed is entered in the Type character box.  The legend
and colors of the touchcell are specified within the Text and Colors index tab.
Custom images can be imported by selecting the Custom radio button within the
General index tab and then selecting the Custom index tab.
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Creating a Pushbutton Touchcell
To create a touchcell as a pushbutton, select the area where the touchcell is to be
located and click on the Pushbutton icon in the Toolbox.  This will display the
dialog box shown in Figure 11-8.

Figure 11-8  

The appearance of the pushbutton is chosen by selecting a radio button from the
Looks portion of the General index tab.  The action of the pushbutton is selected
by picking a radio button from within the Behavior portion of the General index tab.
The legend and colors of the pushbutton are specified within the Text and Colors
index tab.  Custom images can be imported by selecting the Custom radio button
within the General index tab and then selecting the Custom index tab.
The memory location that the pushbutton affects is set by selecting the Reference
index tab and clicking on the Button reference … button.  This will bring up the
dialog box shown in Figure 11-9, which allows you to select the exact memory
location to be written to.  This dialog box will contain the data types that are
present in the PLC being used.

Figure 11-9  
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Creating an Illuminated Pushbutton Touchcell
To create a touchcell as an illuminated pushbutton, select the area where the
touchcell is to be located and click the Illuminated Pushbutton icon in the Toolbox.
A dialog box is displayed, Figure 11-8.
The only difference between an illuminated pushbutton and a pushbutton is that
the face of the illuminated pushbutton can display the status of a bit in the PLC.
The memory location whose status is shown on the face of the button is specified
by selecting the Reference index tab and clicking on the Light reference button.

Creating a Selector Switch Touchcell
To create a selector switch of N states (where N represents an integer from 2
through 4), select an area that is N characters wide, or some integer multiple of N
characters and click the Selector Switch icon in the Toolbox.    To create a 3
position selector switch, the selected area must be either 3, 6, 9, 12 … characters
wide.  The dialog box shown of Figure 11-10 is displayed.  Specify the looks of the
selector switch, as well as the number of states.

Figure 11-10  

Select the Text and Colors index tab, define the legend for each state of the
touchcell, as well as the color scheme for each state (in other words, each state of
the selector switch can have a different color), shown in Figure 11-11.
Select the Reference index tab, to configure the controller memory location that is
affected by each state of the selector switch, Figure 14–12.



11-8 Touchscreen Programming MN1271

Figure 11-11  

Figure 11-12  
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Creating an Indicator Light Touchcell
To create a touchcell as an indicator light, select the area where the touchcell is to
be located and click on the Indicator Light icon in the Toolbox.  The dialog box
shown in Figure 11-13 is displayed.
The legend and colors of the indicator light are specified within the Text and Colors
index tab.  An indicator light can be configured to handle up to 4 different states.  A
different color can be assigned to each state to display the contents of the memory
location in the controller.  The memory location in the controller that the indicator
light is to display is specified within the Reference index tab.

Figure 11-13  

Creating a Generic Command Touchcell
To create a touchcell as a generic command, select an area for the touchcell and
then click on the Generic Command icon in the Toolbox.  This will display the
dialog box of Figure 11-14.  The appearance of the pushbutton is chosen by
selecting a radio button from the Looks portion of the General index tab.
Select one of the three radio buttons within the Functionality portion of the dialog
box and click on the Configure function … button.
Depending on the functionality selection, you will either see a list of panel keys or
a list of macro commands.  If ASCII key is chosen, simply enter the character that
is to be sent in the box beside of the ASCII key radio button.  The legend and
colors of the pushbutton are specified within the Text and Colors index tab.
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Figure 11-14  

Figure 11-15  

An LED indicator can be added to a touchcell if, within the Looks portion of the
General index tab, Windows, Windows + Custom, or Custom is selected.  The
Reference index tab appears as shown in Figure 11-15.
Select the Attach to controller reference box allows you to click the Button
reference … button and specify a bit in the controller whose status will be
displayed by the LED on the touchcell.
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Multilanguage with Touchcells
With Designer version 5.05 and later, and firmware version 4.20 and later, it is
possible to integrate multiple languages within the same touchcell.  Whenever a
user defines a touchcell in a project file that has more than language created, an
additional button will be present in the Text and Colors index tab called Change
Language.  Clicking this button displays the Language floating toolbar that allows
you to choose a language to work in.  Specify the text for the touchcell in each
language that is used in the project file.  See the chapter on Multilanguage for
more information about multiple languages within a single project file.

Special Pages and Page Modes
The items located within the Special Pages and Page Modes portion of the Page
menu (Figure 11-16) include Data Entry Screen, Command Menu, System,
Passwords, Direct Access, Direct Page Selection, Time & Date, Alarm Page,
Event Page, and Current Page Mode.  Place any combination of static text and
touchcells on these pages.  Place these items on the lower portions of the page,
because these modes reserve some of the area in the upper portions of the page
for display information.
Whenever the panel enters Password mode or Data Entry Mode, a numeric
keypad is displayed.  In all of the other modes, a row of keys is displayed that
contains the arrow keys, an ENTER key, and a CLEAR key.  The keys will not be
displayed if a custom screen is created.  To create a custom screen that contains
static text and touchcells, select Page→Special Pages and Page Modes from the
main menu.

Figure 11-16  
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Digital Touchscreen Menu As mentioned earlier, users with our digital touchscreens will have a
different set of menu options presented to them upon opening the TouchScreen
menu.  The two choices available are Show Touchscreen Grid and Show Key
Assignments.  The touchcells are programmed using the Keyboard Macro Editor.

Show Touchscreen Grid This option displays a grid on the screen to assist in programming the
touchcells.  You can see the true boundaries of each touchcell on the page.

Show Key Assignments This option is available after Show Touchscreen Grid is selected.
Selecting this will show the key assignments for the panel (see Figure 11-17).
Note that the touchcells are in fixed locations.  The HELP, CLEAR, and ENTER
keys are pre–defined and should not need be changed.  This is also true for the
numeric keypad and the left and right ARROW keys.
The touchcells are programmed using the Keyboard Macro Editor to perform a
vast array of functions, such as changing pages of the project file, scrolling down a
line, entering Data Entry Mode, and writing a value to the controller.

Figure 11-17  
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Example
Configure a touchcell to write a value to the controller.

1. Select Show Touchscreen Grid from the Touchscreen menu.  A grid is
displayed, to help program the touchcell.

2. Highlight the area the touchcell is to be located.  In this example, let’s
assume that if the user presses touchcell locations F21 or F22, the panel
will write a value to the controller.  Click and drag the mouse to highlight
the area encompassing cells F21 and F22.

3. It is suggested to program the touchcells with a reversed attribute when
they are pressed.  In this manner, the operator will have immediate
feedback when the cell is pressed.  This is done within the Keyboard
Macro Editor.  Since the work area is highlighted, start the Keyboard
Macro Editor by either clicking the proper icon in the Extra ToolBelt or
select Project→Keyboard Macro Editor.

4. This will bring up the Keyboard Macro Editor dialog box.  This cell is
being programmed for F21 and F22, begin with F21.  Scroll through the
keys at the top of the dialog box until F21 is highlighted.

5. Click on the Pressed radio button and the select the Page n index tab.
This allows the touchcell to perform it’s assigned function only on this
page in the project.

6. Select the Attribute icon from within the Commands toolbar.  Select the
Reverse attribute.  Since the area is highlighted, the dimensions are set
automatically.

7. It is necessary to set a small delay for the user to see the attribute before
turning off the attribute.  Click the Wait icon and enter a 3 in the dialog
box.  This will add a 3/10 second delay.

8. Now turn the attribute off.  Selecting the Attribute icon and uncheck all of
the attribute options.

9. The next step is to write the value to the controller (assume a value of
10).  Click the Write to Controller icon.  This displays a dialog box to
enter the specific controller address.  Enter the address and click OK.  A
dialog box to specify the value to be written is displayed.  Enter 10 and
click OK.

10. The macro screen should look like Figure 11-18.
Repeat these steps for the F22 key.  Select the F22 key and repeat steps 5
through 9.  Next, add some static text or a rectangle to the area to let the operator
know the functionality of the touchcell.
Note:  Rectangles are added by selecting Rectangles & Symbols from the Edit

menu.  This will display a dialog box (Figure11-19) to select which one to
use and press Exit.  Text is added by simply moving the cursor inside the
rectangle and typing.



11-14 Touchscreen Programming MN1271

Figure 11-18  

Figure 11-19  

The result may resemble Figure 11-20.
Figure 11-20  
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Multiple languages can be supported with a single project file.  The language that
the project file uses is selected at run–time.  To set up your languages, select
Project→Languages.  The dialog box of Figure 12-1 is displayed.

Figure 12-1  

Click the Add… or Insert… buttons to add a new language.  A prompt asks for the
new language name.  The Edit… button is used to change the language name.
The Remove button is used to remove a language from the list.  Set Default button
is used to make the selected language the default language for programming.
Example
Assume you want to have a project file that contains text in English, Italian,
German, Spanish and French.  Your Languages dialog box may resemble the one
shown in Figure 12-2.

Figure 12-2  
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You will now be able to enter text in any of the languages listed in Figure 12-2.
For each language, you will still be using the standard ASCII character set.
Designer does not translate between languages.  Therefore, if you enter text in
English and then select Spanish as the language, you will also have to enter the
text in Spanish.  To choose a language to work in, select Project→Select
Language.  The dialog box of Figure 12-3 is displayed.

Figure 12-3  

Figure 12-4 shows the project file used with the English language, Figure 12-5
shows the same project file used with the Spanish language.
The cut/copy/paste commands work in the usual way unless the “Multilanguage
Mode” in the Edit menu is set.  If “Multilanguage Mode” is not set, the
cut/copy/paste commands operate only on the language currently active.  If
“Multilanguage Mode” is set, the commands operate on all the languages.  It is
important to mention that multilanguage can also be used with the alarms and
message fields.
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Figure 12-4  

Figure 12-5
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Changing the Language After Downloading
To change the language that the project file uses once it has been downloaded,
create a control variable with a data type of Language.  To create this control
variable, three steps need to be performed:

1. Select Edit→Data Field Source→Panel Control Variable.
2. Select Edit→Data Field Type→Numeric/ASCII.  This will display the

Control Variable field dialog box.
3. Underneath Data Type, select Language.  Make sure that this field is

created as read/write so that it can be edited.

To change the language that is being used, the user must increment or decrement
this field.  This is done in one of two ways.

� One way is to simply edit the field and enter the number of the language
that you want to use (in our example, English would have a value of 1,
German would have a value of 2, etc.).

� The other way is to program a key or a touchcell using the macro
command Control Variable Step to increment the value of the language
control variable field, and another key or touchcell to decrement the
value of the language control variable field.
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Printing a Project
Once a project has been completed, it may be documented by generating a
printed report.  With the desired project loaded into Designer, select Print from the
File menu.  This will bring up the dialog box that is shown in Figure A-1.

Figure A-1  

Select the desired report style, click the respective checkbox.
Summary – Includes application setup parameters and page statistics.
Pages – Prints all page data, including a complete description of page text

and data fields.
Variables – Prints all the variables defined in the project.
Alarms – Prints a complete list of alarm messages defined in the project

including the priority level and alarm attributes.
Passwords – Prints a list of all passwords and privileges.
Macros – Prints a complete list of macros defined in the project.
All – Includes all the information contained in the options above.

Note: It is recommended to print in Text mode.
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Initialization Files
DESIGNER.INI DESIGNER.INI is used to store the latest configuration of the Designer software

upon exit.  Each time you start the Designer, this information is used to restore the
page editor workspace, panel setup, and communications parameters.

[Designer] Initial start–up values
ToolBelt 1=Show, 0=Hidden
ToolBelt1 1=Show, 0=Hidden
Statusbar 1=Show, 0=Hidden
ZoomSize Initial zoom just after start–up, allowed values are: 1 – 5
GridMode 0=No grid, 1=Point grid, 2=Line grid
TargetLib Last controller library used
ApplPath1 Last project file opened
ApplPath2 Second most recent project file opened
ApplPath3 Third most recent project file opened

[Graphics Library]
ApplPath1 Where graphics files are located

[Communications] (PC  to  Panel)
CommPort 1=COM1, 2=COM2, 3=COM3, 4=COM4
BaudRate 300, 600, 1200, 2400, 4800, 9600, 19200, 38400
Parity None, Odd, Even
StopBit 1 or 2
DataBits 7 or 8

[Net Communications]
BaudRate 300, 600, 1200, 2400, 4800, 9600, 19200, 38400, 57600
Parity None, Odd, Even
StopBit 1 or 2
DataBits 7 or 8

[Panel Setup] Initial values for panel setup dialog
DisplayType Last display used
Font Last font used
InternalRam Panel memory
DateFormat MM/DD/YY or DD/MM/YY
TimeFormat 12:00:00 or 24:00:00
TouchUsed 0=Not used in last project, 1=Used in last project
LastTouch Touchscreen code
[Touch Font]
FaceName Last touch font used
LFData Various font characteristics
[IOModules]
NumModules Number of supported I/O modules
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[PLC Communications]
BaudRate 300, 600, 1200, 2400, 4800, 9600, 19200
Parity None, Odd, Even
StopBit 1 or 2
DataBits 7 or 8

[Panel Printer]
PrinterType TTY–printer
BaudRate 300, 600, 1200, 2400, 4800, 9600, 19200
Parity None, Odd, Even
DataBits 7 or 8
StopBit 1 or 2
PageWidth Number of characters printable across page
PageLength Number of printable rows per page
AutoLF 0=Off, 1=On
UseFFLF 0=Off, 1=On
Protocol 0=None, 1=XON/XOFF

[Look]
Look 0=Light Background, 1=Dark Background

[Panel Capabilities]
1.2 Flags for creating ROM files
3.19 When creating ROM files, select the highest firmware
3.99 version closest to the one contained in the panel
4.2

[Modem Info]
Enable    0=No phone list or dialing menu present, 1=Present
LastCall    Last number dialed
DialPrefix    Modem dialing prefix
DialSuffix    Modem dialing suffix
Init    Modem initialization string
Hangup    Modem hangup string
DropDTROnHangup 0=No, 1=Yes
Connect    Modem connection message
NoConnect1    First non–connection message
NoConnect2    Second non–connection message
NoConnect3    Third non–connection message
NoConnect4    Fourth non–connection message
[Phone List]   Filled in when modem menu options are used

Displays.ini DISPLAYS.INI should NOT be altered.  Designer uses this file internally to initialize
various dialogs and other data.
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FlexDrive Information
RS232 protected communication is used to allow communication between the HMI
panel and the Flex or Flex+ control.  At the panel setup menu, either a FlexDrive
or Flex+Drive may be selected.  The communication driver provides full access to
the parameters of the servo control.

Figure B-1  

To configure the HMI panel for a Flex or Flex+ control, start the Designer software
and do the following:    (see Figure B-1).

1. Select Project→Change Controller Driver and choose Baldor Flex.
2. Select Project→Panel Setup menu and choose the panel.
3. The Real Time Clock information in the RDA (Reserved Data Area) is

coded in BCD. The RDA information should be placed in the panel
Internal Buffer memory since no memory is available in the Flex drive.

4. To define the drive parameters, insert a field (right click on the project
page).  The dialog box of Figure B-2 is displayed.  Parameter names are
given in Appendix B of MN1275 (for Flex) and MN1276 (for Flex+).

Figure B-2  
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5. Select the Data Type from the drop down menu.
6. The internal panel buffer is 256 bytes of memory area used for the RDA,

the mailbox etc.
Error Codes Communication status information is displayed in the System Menu. The error

status is described by a message and a numeric error code. The numeric error
code is the code of the current communication error. When the error code is 0, no
communication errors have occurred since system start–up.

Code Description Notes
0 No error There are no communication errors and there have been no

errors since start–up.
04 NAK response The controller didn’t accept the request, it returned a NAK
05 Timeout The controller didn’t respond to the request within 2 seconds
06 Response error Buffer overrun. The controller sent more than 250 bytes in the

response
08 No application response data Some application response data was expected but the re-

sponse contained no data
09 Unespected response data There were unexpected characters in the application re-

sponse data
11 Line error Bad Baud rate, parity etc
12 Bad application response data There were invalid characters in the application response

data

Other Information
1. RS232 connection is made between the PLC Port of the HMI panel and

the X6 connector of the Flex or Flex+.
2. The cable part number is CA55.
3. Use 9600 Baud, 8 data bits, 1 stop bit, no parity.
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MintDrive RS232 protected communication is used to allow communication between the HMI
panel and MintDrive, SmartMove or NextMove Box controls.  The panel can read
and write data to all 99 ‘Comms Array’ variables.

Hardware Connection
1. RS232 connection is made between the PLC Port of the HMI panel and

the 9 pin sub D type connector of the control.
2. The cable part number is CA55.

Software Setup
Figure B-3

To configure the HMI panel for a Flex or Flex+ control, start the Designer software
and do the following:    (see Figure B-3).

1. Select Project→Change Controller Driver and choose Baldor.
2. Select Project→Panel Setup menu and choose the panel.
3. Click “Ctrl Comm...”and set the serial port parameters to 9600 Baud, 

8 data bits, 1 stop bit, no parity (can be set as high as 57600 baud).
4. Enter the node address in the Slave ID box.

Figure B-4  
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The controller’s Mint program must be running for communication to take place
between the HMI Panel and SmartMove.
All read/write data has three decimal places. The range is ±2147483.647.

SmartMove RS232 protected communication is used by placing the COMMSON keyword in
the Mint Configuration file.  If there is an AUTO instruction in the configuration file
(to execute the Mint program on power up) then COMMSON should be placed as
the second line in this file. If there is no AUTO instruction then COMMSON should
be placed as the first instruction in this file.
The controller’s Mint program must be running for communication to take place
between the HMI Panel and SmartMove.  The serial port on the SmartMove
controller is configured for operation at 9600 baud, 8 bits, 1 Stop bit, No parity –
(be sure the Project→Controller Setup is configured properly).
All read/write data has three decimal places. The range is ±2147483.647.

NextMove Box RS232 protected communication is used by placing COMMSMODE.tmRS232=1 in
the Mint configuration file or program file.  Configure the NextMoves serial port for
9600 baud, 8 bits, 1 Stop bit, No parity (can be set as high as 38400 baud via the
SERIALBAUD keyword).  Refer to Baldor’s Mint for NextMove manual for further
details)  Be sure the Project→Controller Setup is configured properly.
The controller’s Mint program must be running for communication to take place
between the HMI Panel and NextMove.
All read/write data has four decimal places. The range is ±2147483.647.

MintDrive and SmartMove Examples:
To format displayed data the scaling equation (y=mx+c) can be used to fit the
number of decimal places actually required on the screen.
Data to be displayed using 3 decimal places:

Format numeric value for fixed point with a placement of 3.
Scaling should be set to y = 1 / 1 x + c

Data to be displayed using 2 decimal places:
Format numeric value for fixed point with a placement of 2.
Scaling should be set to y = 1 / 10 x + c

Data to be displayed using 1 decimal place:
Format numeric value for fixed point with a placement of 1.
Scaling should be set to y = 1 / 100 x + c

Data to be displayed as an integer value:
Deselect the fixed point option (placement of 0 by default)
Scaling should be set to y = 1 / 1000 x + c
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CANopen Dynamic Link Library
To program an HMI panel, the Designer program is used. The CANopen dynamic
link library (dll) included with Designer must be updated. After installing Designer,
follow these instructions:

• Copy the new dll (’UPLC107.DLL’) to the Designer folder on your hard
drive  (this is C:\Program Files\Designer if you used the defaults).

• Ensure that the panel is connected to the PC (serial cable) and the panel
is powered up.

• Start Designer.
• Verify the communications set–up by selecting . Select the appropriate

serial port in use, baud rate 9600, No Parity, 1 Stop bit
• Put the panel into configuration mode by pressing and holding down the

’Enter’ key for 4 seconds
• Select configuration mode (’CFG’) using the arrow keys and press

’Enter’
You must now delete the old protocol from the panel, by:
• From the menu, select <Transfers> then <Options...>.
• Click on the ’Advanced Options >>’ button, then click on the ’Erase

Protocol’ button.
• Answer ’Yes’ in the question box that appears.  This should return an OK

message.
• Make sure that the ’Both’ radio button is selected in the ’Download’ box

in the ’Transfer Options’ Window.
• Select the new CANopen driver (v3.04) from ’Project .. Change

Controller Driver’
The next time you download a project, the new CANopen protocol will be used.

Creating a Project File
Getting Started
When you start Designer a new (Untitled) project workspace is displayed.

1. Select Project→Panel Setup and select the panel.  This example uses
an 8x40 LCD graphic unit – Click OK when ready.

Figure C-1 
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2. The screen work area will change shape to suit the panel chosen – the
yellow area indicates the immediately visible area. The grey region can
also be used to place controls etc.  (For this example, everything is
placed within the yellow area.)

3. Select Project→Controller Setup menu.  The CANopen address (Panel
NodeID) and baud rate must be set.  Figure C-2.

The Panel NodeID must be set to a value other than 1 (1 is reserved for
the CANopen master node – the MintDrive).

The baud rate must be set to a value that is supported by the controller
(50,125,250,500,800 or 1000 kbps for MintDrive).

Figure C-2  

4. At this point it is probably worth saving the Project (File→Save).  Save
often to avoid loosing your project file.

Adding Labels to the Screen
5. For this example, we will create screen labels for actual MintDrive data

values of “Actual Speed”, “Drive Mode” and “Error Status”.  Click at the
start point for each label and type the appropriate text. Your screen
should look as shown in Figure C-3.

Figure C-3  
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Adding Floating Point Data
6. Click and drag the mouse to cover the area the data is to fill – e.g. Actual

speed will be in the range 0–100 so click and drag over 3 squares to the
right of the equal sign, Figure C-4.

Figure C-4  

7. Use the right mouse button to click on this shaded area and the dialog
box of Figure C-5 is displayed.  The fields are as follows:

Figure C-5 

Data Type
There are two possible data type selections – Int32_db (for integer data) and
float_db (for floating point data). The Data Format selection should always default
to DBLE WORD (Bin) for integers and FLOAT for floating point values. For our
actual speed data we might choose to display this as a floating point value.
Index
The index is a reference to the effective comms location that the Mint program will
use.  For each data type (Int32 and Float) there are 254 available indexes.
Note: The panel uses a hexadecimal numbers for the Index while MintDrive uses

decimal numbers.
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The HMI data is mapped as follows
HMI Panel MintDrive

Int32_db Index 1 to Int32_db Index FE Comms(panel_node,1) to Comms(panel_node,254)
Float_db Index 1 to Float_db Index FE Comms(panel_node,255) to Comms(panel_node,508)

The panel_node variable is the value used for the Panel NodeID in Figure C-2.
Because this is the first Floating point variable defined we choose Index 1.

Display Format
This is Numeric when specifying a data field. Option buttons allow you to choose
between signed and unsigned numeric formats (select Signed for this example).
Numeric Base
This allows selection of Decimal or hex – MintDrive uses decimal.
Data Access
Select Read Only (for display only) or Read/Write (so the data can be read by the
MintDrive).  For this example,choose read only (MintDrive writes the data).
Field Dimensions
Originally we highlighted 3 squares (because 0–100 requires 3 digits).  We can
change the Field Width, perhaps 4 digits would be better.  Using the Field Width
field and the Fixed Point button we specify the field length and decimal places.
Note The decimal point itself is a character so for a xxx.x format display the field

width is 5 characters.
Field Height allows the text height to be adjusted.  Use 1 for this example.
Scaling
Data sent to the panel may be scaled by the Mint program and/or the Panel. This
option allows entry of a simple y=mx+c format modifier to the data received by the
panel. The modified data is then displayed rather than the received data. For this
example we will not scale the received data (all scaling will be done by the Mint
program)
Fixed Point
Select this option if the field has decimal places to be displayed. The placement
indicates the number of digits to follow the decimal point. For this example, select
‘Fixed Point’ and enter 1 for the Placement.
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Adding Message Fields
8. The Drive Mode field of Figure C-3 is to display a particular message

depending on a value written by the controller.  Click and drag the
mouse to cover the area the data is to fill.

9. Click the ‘Text Message Field’ button in the toolbar or select 
Edit→Data Field Type→Message at the top menu.  The the dialog box of
Figure C-6 is displayed.

Figure C-6  

10. The designer software automatically sets the data type and index to the
last values used.  For the drive mode, use an integer value to represent
the mode, Table C-1.

Table C-1
Drive Mode Represented by
In Error 1
Idle 2
Homing 3
Move in Progress 4
Fly in Progress 5
Cam in Progress 6
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For this example, complete the dialog box selections as follows:
Data Type: Int32_db
Index: 1 (this is the first Int32 we have specified)
Data Format: DBLE_WORD(Bin)
Display Format: Message – Unsigned
Data Access: Read Only
Field Dimensions: Set these according to the space you have made available
(you should have about 25 characters available) – stick with a field height of 1.
Min Value: 0
Max Value: 6
Note You may be wondering why the Min Value is 0 when we specified the

controller modes in the range 1 to 6. The reason is that if the controller is
offline the panel will receive a value of zero for the message data.  When a
zero is received, the ‘Controller Offline’ message is displayed.

11. Click the ‘Edit Message’ button. You will see a dialogue box (Figure C-7)
that allows a message for each of your data values to be entered.  Use
the Up/Down arrow keys to move between messages and type to enter
the appropriate text. Click OK when finished.

Figure C-7  

Your screen should now resemble this.
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Adding Integer Data
12. The last label “Error Status” will display an error code (numeric integer

value) that is set by the MintDrive. This error code could be up to 4 digits
in length.  Click and drag over 4 squares to the right of the Error Status
label and right click as before.

Figure C-8 

13. This data is our second integer value (the first was used for the previous
message field), so we will use Int32_db Index 2.  Complete the dialog
box as shown in Figure C-9.  Click OK when finished.

Figure C-9
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So far we have specified the three data fields shown in Table C-2.
Table C-2

Description Field Type Exor Data Type Controller Data Type
Actual Speed Numeric Float_db Index 1 Comms(2,255)
Drive Mode Message Int32_db Index 1 Comms(2,1)
Error Status Numeric Int32_db Index 2 Comms(2,2)

Adding Data Entry Features
1. Add data fields to allow the MintDrive to read panel data.  For this

example we are going to allow data entry of:
a. Required Speed (1–100 products per minute) –

format xxx.x – Float_db Index 2
b. Product Length (1–200 mm) – format xxx.x – Float_db Index 3
c. Product Gap (0–50mm) – format xx.x – Float_db Index 4
Add text labels to the screen as follows:

2. Click and drag the area into which the required speed will be entered
and right click to enter the field details. Repeat for the other two fields.
All of these values will be unsigned and data access will be set to
read/write.
Your screen should now resemble this.
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Programming a Function Key
The panel has a number of Function Keys that can be programmed to perform
various functions (e.g. Goto Screen, scroll up, write to controller, print etc.)  We are
going to use Function Keys F1 to F5 (A/B, C/D, E/F, G/H, I/J) to effectively write
data to the controller (remember the controller is the master and actually reads the
data). These keys will set the required mode of operation (home, move, fly, cam,
stop). Each key will use the same location – the data will change according to the
required mode (home=1, move=2, fly=3, cam=4, stop=5).
This is accomplished as follows:

1. Select the Macro Editor (the button on the toolbar with the ‘F1’ icon or by
selecting Project→Keyboard Macro Editor).  The Macro Editor of Figure
C-10 is displayed.

Figure C-10  

The top portion of this dialog shows all of the panel keys that can be
programmed (scroll left/right to view all). Beneath this is the “Key
States”: Pressed, Released and Autorepeat.
The eight tabs represent the operating modes that can be selected for a
function key.   If an operating mode has been selected, the yellow circle
on the appropriate tab will turn red.
Below the tabs are the command buttons (use the right arrow button at
the end of the list to scroll on to further commands).
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2. For our example, program keys F1 to F5 as follows:
a. Select the key to be programmed (F1 etc.).
b. Select the “Pressed” Key States.
c. Select the mode: active on Page 1 only (select the Page 1 tab).
d. Select the ‘Write to Controller’ command (13th button from the left).

 The dialog box of Figure C-11 is displayed.

e.
Figure C-11

All five keys will write data to Int32_db Index 3 (the MintDrive will read this as
Comms(2,3)) so ensure the data type is set to ‘Int32_db’ and the Index is set to ‘3’
as in Figure C-11.  Click OK when finished to display the Figure C-12 dialog box.

Figure C-12  

This allows you to specify the data value to be read by the controller when the key
is pressed and released.  For this exercise F1 will write 1, F2 will write 2, F3 will
write 3, F4 will write 4 and F5 will write 5.
Repeat this procedure for each function key.
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The programming of the panel I/O is complete.  The fields we have programmed in
this example are summarized in Table C-3.  The final step is to download the
project to the panel memory.

Table C-3
Description Field Type Exor Data Type Controller Data Type
Actual Speed Numeric Float_db Index 1 Comms(2,255)
Required Speed Numeric Float_db Index 2 Comms(2,256)
Product Length Numeric Float_db Index 3 Comms(2,257)
Product Gap Numeric Float_db Index 4 Comms(2,258)
Drive Mode Message Int32_db Index 1 Comms(2,1)
Error Status Numeric Int32_db Index 2 Comms(2,2)
Mode Command Key Press Int32_db Index 3 Comms(2,3)

Downloading a Designer Project
Use the following procedure to download your project to the panel:

1. Be sure the PC and panel serial ports are connected.
2. Press and hold the panel enter key for 4 seconds (to access the menu

section).
3. Use the arrow keys on the panel to navigate to the CONFIG menu and

press enter (the panel should now indicate it is in Configuration mode).
4. In Designer either press F2 or select “Transfers→Download” from the

menu.  When the download is complete the panel will resume Operation
Mode automatically.

Until the panel is connected to the controller there isn’t too much to verify.  To
prove you have entered the min and max limits correctly, you could experiment
with Data Entry as follows:

1. To enter Data Entry mode press the 0 key on the keypad.
2. Now use the arrow keys to move to the variable you want to enter.
3. Try entering a valid number.
4. Try entering a value that’s out of range and note the result.

Writing Mint v4 Code
The following Mint v4 application segment (usually part of the Config file) will
initialize the panel on start–up.
commsmode=0             :rem CANopen
bus=1                   :rem CANopen is port 1
node=1                  :rem Controller must be CAN master (1)
canbusreset             :rem CANBus reset
canbaud=500             :rem 500 Mbaud to suit Designer settings
wait =10000             :rem Wait 10 seconds – dependant on Exor panel
startup time
while !nodelive.2
     nodescan.1.2       :rem Look for Node 2 (the panel) on bus 1
     if !nodelive.2 then ?”Panel failed to respond”
endw
rem Once panel is live make a CAN connection...
while connectstatus.2 <>8 :rem Value of 8 indicates connection made to
panel
  connect.1.2=1
  if connectstatus.2<>8 then ?”Connection to Panel failed”
endw
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For Mint programs, use the DEFINE command to create text substitution for the
various Comms locations in use. As an example:
DEFINE reqd_speed = Comms(2,255)

In this way the text “reqd_speed” can be used throughout the program in place of
“Comms(2,255)”.  This makes the program much easier to understand or update.
One important thing to note is that the Comms data is all stored on the panel. The
MintDrive is the master (i.e. it writes data to the panel and reads data from the
panel). When the panel is switched off, the data is lost. If you need retentive data
(e.g. required speed may need to be retentive), then ensure a Mint variable is
used to keep a record of the value.
Example:
Dim _reqd_speed : rem Local value for speed demand
_reqd_speed = reqd_speed : rem Set local value to that defined as
                           Comms(2,255)

Mint controller variables are non–volatile – these can then be used on program
start–up to ‘reinstate’ the last known (working) values.
e.g. reqd_speed = _reqd_speed : rem Set Comms(2,255) to value held by local
variable
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Acknowledgement An action performed by the operator in response to an alarm message.
Alarm flag A flag bit is set when an event is detected by the control. This flag is passed to

the panel for display.
Alarm handling flags A set of alarm flags, set or reset by the user during the configuration phase,

which determine the way the corresponding alarm is handled by the Panel.
Baldor HMI Software  A software program used to create a panel application program.
Configuration An initialization procedure to define all panel parameters.
Configuration Mode A panel mode that allows communication to a PC for configuration.
Control A Motor Control or PLC to which the panel is connected.
Data block A basic data structure in the PLC internal memory.
Data field A basic element of the data structure to store a variable specified during

configuration.
Downloading The process of loading a program from the PC to panel memory.
Dynamic entries One or more data fields that store present values of variables for display.
Event The setting and resetting of alarm flags, as well as alarm acknowledgements.
Function keys A set of keys that have user–defined functions.
Host A PC that is running the Baldor HMI Software and communicating with the

panel.
Log–in A process to identify the operator (by password) and set operating privileges.
Operation Mode A panel mode that runs an application program in panel memory.
Page A basic structure for presenting application data on the display. Up to 32 lines

of information is displayed (depending on the panel).
Page window The part of the Baldor HMI Software used to define the layout of the Pages.
PLC A Motor Control or PLC to which the panel is connected.
Project file An application program file created and stored on the host PC and

downloaded to the panel for execution.
Read only A variable or memory location that can be read but not modified.
Read/Write A variable or memory location that can be read and modified.
Reserved data Areas Areas of PLC memory for communication between the PLC and the panel.
Resources The built–in display and the application memory are called panel resources.
Setup A procedure to define all panel parameters also called configuration.
Stand–alone operation A panel is said to be operating stand–alone when it is running its application

program and is connected to the PLC, but not to the host PC.
Static entries The fixed part of the Page, created in the form of text comments that describe

the data displayed in data fields.
System memory area A part of PLC internal memory to store PLC structures (timers, counters, flags,

inputs and outputs).
Uploading The process of loading information from panel memory the PC memory.
Variable The value of a process quantity that is dependent on the state of the process

or machine being controlled.
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